Package Details: obs-ndi-bin 4.9.1-1

Git Clone URL: https://aur.archlinux.org/obs-ndi-bin.git (read-only, click to copy)
Package Base: obs-ndi-bin
Description: Network A/V in OBS Studio with NewTek's NDI technology
Upstream URL: https://github.com/Palakis/obs-ndi
Keywords: libndi obs-ndi
Licenses: GPL2
Conflicts: obs-ndi-git
Provides: obs-ndi
Submitter: joow
Maintainer: shaybox
Last Packager: shaybox
Votes: 9
Popularity: 0.000020
First Submitted: 2017-10-10 19:54 (UTC)
Last Updated: 2020-05-14 20:31 (UTC)

Latest Comments

Jat commented on 2020-05-26 03:44 (UTC)

plz remove /usr/lib/x86_64-linux-gnu. arch does not use this location

TomCatT commented on 2020-05-07 23:54 (UTC)

@emileet HA!!!! THANK YOU SO MUCH. I was thinking way to deep for this and it was as simiple as that.

emileet commented on 2020-05-07 05:49 (UTC) (edited on 2020-05-07 05:49 (UTC) by emileet)

@TomCatT remove libndi3-bin and install obs-ndi-bin with libndi-bin as it supersedes libndi3-bin.

TomCatT commented on 2020-05-07 02:52 (UTC)

Has anyone received this error?

error: file owned by 'libndi-bin' and 'libndi3-bin': 'usr/lib/libndi.so'

shaybox commented on 2020-05-05 01:54 (UTC)

@terodero I notified the developer that their change broke it, they changed the path which only Ubuntu's patched obs reads from, instead of the official path, until they change that i'll implement a fix.

emileet commented on 2020-05-04 11:10 (UTC)

here's a patch to fix the issue https://github.com/emileet/patches/blob/master/aur/obs-ndi-bin/plugin-dir.patch

i also provide obs-ndi which doesn't have this issue

terpderp commented on 2020-05-03 23:21 (UTC)

I am curious if this is just me, but I had an issue with the 4.9.0 release. The plugin seemed to disappear from OBS. It seems to install the plugin to /usr/lib/x86_64-linux-gnu/obs-plugins when other obs plugins are installed /usr/lib/obs-plugins. OBS doesn't see it is a plugin (OBS 25.0.8.1).

This is referenced in the 4.9.0 release here https://github.com/Palakis/obs-ndi/releases/tag/4.9.0 as a bugfix for Ubuntu/Debian.

Copying the plugin from /usr/lib/x86_64-linux-gnu/obs-plugins to /usr/lib/obs-plugins fixes it and works as expected.

shaybox commented on 2020-04-29 06:11 (UTC)

@emileet fixed

emileet commented on 2020-04-17 22:04 (UTC)

easy fix for the perms would be to append this to the PKGBUILD

chmod 755 $(find "${pkgdir}" -type d)

Freso commented on 2020-04-17 21:40 (UTC)

Directories (at least some of them) are given 777 permission instead of 755 permissions, meaning that if they get installed by this package they will be world writeable.

Freso commented on 2020-01-11 18:16 (UTC)

Then put that as a dependency… as long as the package depends on some ndi library that it works with.

shaybox commented on 2019-12-26 19:54 (UTC)

I switched it to use libndi3 from the developer of obs-ndi, basically the same thing but its version tested for obs-ndi.

guitaristtom commented on 2019-12-26 11:16 (UTC)

@Freso is right. You have to add ndi-sdk back in as a dependency, otherwise people will continue to get errors when they start up OBS.

Freso commented on 2019-12-15 23:33 (UTC)

Did you intentionally drop the ndi-sdk dependency? The OBS plugin doesn’t work without it.

shaybox commented on 2019-12-15 21:38 (UTC)

I hope this works for everyone, I updated both obs-ndi-bin and libndi3-bin, they work for me <3 Let me know of any changes that need to be made

Freso commented on 2019-10-23 12:39 (UTC)

The PKGBUILD needs two lines changed to work properly:

diff --git a/PKGBUILD b/PKGBUILD
index 620e78b..5e66a11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
 # Maintainer: Thomas Hine <thomas @ thomashine.xyz>
-pkgname=obs-ndi
+pkgname=obs-ndi-bin
 _pkgname=${pkgname%-bin}
 pkgver=4.6.0
 _pkgbuild=1
@@ -12,7 +12,7 @@ provides=('obs-ndi')
 conflicts=('obs-ndi-git')
 depends=('obs-studio' 'ndi-sdk' 'avahi')

-source=("${url}/releases/download/${pkgver}/${pkgname}_${pkgver}-${_pkgbuild}_amd64.deb")
+source=("${url}/releases/download/${pkgver}/${_pkgname}_${pkgver}-${_pkgbuild}_amd64.deb")
 sha256sums=('eaf0d451527037b0e1b9af5ad69a3aaffc7b583819a45d6f774e846cd2253e03')

 package() {

fthiery commented on 2019-08-21 08:31 (UTC) (edited on 2019-08-21 08:31 (UTC) by fthiery)

Also ran into the "Could not find PKGDEST" error. I worked around it by not using any aur helper, but:

git clone https://aur.archlinux.org/obs-ndi-bin.git && cd obs-ndi-bin && makepkg -si

TimothyCole commented on 2019-08-15 03:45 (UTC)

Can't install Could not find PKGDEST for: obs-ndi-bin

Gelmo commented on 2019-06-14 04:04 (UTC)

Works fine in yay and trizen with a couple small changes:

https://glot.io/snippets/fd58w3iyxx

buresu commented on 2019-06-06 12:17 (UTC)

The installation fails with the following message: Could not find PKGDEST for: obs-ndi-bin

TomCatT commented on 2019-05-31 14:11 (UTC)

obs-ndi: /usr/lib/obs-plugins/obs-ndi.so exists in filesystem (owned by obs-ndi-bin) obs-ndi: /usr/share/obs/obs-plugins/obs-ndi/locale/en-US.ini exists in filesystem (owned by obs-ndi-bin) obs-ndi: /usr/share/obs/obs-plugins/obs-ndi/locale/fr-FR.ini exists in filesystem (owned by obs-ndi-bin) Errors occurred, no packages were upgraded.

Are you able to add to the script so that it can check to see if these files are here or not? If so, remove them and the installation will work.

TomCatT commented on 2019-04-23 01:56 (UTC)

Okay you can manually install it and it runs just fine but once I fire up my streaming computer it crashes. I hope everyone made a system backup so they may restore this until it is fixed.

I'm going to try the source code and see if this fixes it.

TomCatT commented on 2019-04-20 22:41 (UTC)

BUMP

medzernik commented on 2019-04-19 10:16 (UTC)

This package is not installable via the YAY helper. Reason unknown.

guitaristtom commented on 2018-10-02 04:20 (UTC) (edited on 2018-10-02 04:53 (UTC) by guitaristtom)

Maaaan. I was hoping to mess around with this tonight... but it's still out of date (looks like we have been waiting 1.5 months so far) :/

Maybe I'll just update it myself ;)

Gelmo commented on 2018-08-19 11:35 (UTC)

Need to change pkgver to 4.5.0 and replace libndi3 with ndi-sdk.

gibbz commented on 2018-04-28 06:48 (UTC)

This isnt working on any of the machines ive tested this on. I can see the name of the NDI stream in obs, so I know that part is working. But I get no audio or video, just blank in the preview, and blank in obs.

Is there something else that needs to be installed for this to work?

pschichtel commented on 2018-03-30 16:52 (UTC)

A dependency on Avahi would be good, as it is definitely required for source discovery.

joow commented on 2018-01-26 17:57 (UTC) (edited on 2018-01-26 17:57 (UTC) by joow)

I've updated the package to version 4.2.2

Let me know if there is any issue.

jbrouhard commented on 2018-01-25 04:30 (UTC)

Current version is 4.2.2-1 I would love to see an update as I'd like to try to get this working on arch!