Package Details: obs-service-source_validator 0.6+git20160707.a6ff89d-1

Git Clone URL: https://aur.archlinux.org/obs-service-source_validator.git (read-only)
Package Base: obs-service-source_validator
Description: An OBS source service: running all the osc source-validator checks
Upstream URL: https://build.opensuse.org/package/show?package=obs-service-source_validator&project=openSUSE%3AFactory
Licenses: GPL2
Conflicts: osc-source_validator<=0.1
Provides: osc-source_validator=0.6+git20160707.a6ff89d
Submitter: ilpianista
Maintainer: fusion809
Last Packager: fusion809
Votes: 3
Popularity: 0.000000
First Submitted: 2011-09-30 10:31
Last Updated: 2016-09-20 06:44

Latest Comments

JonnyJD commented on 2016-03-13 11:40

Hm, looks like an upstream issue. Thanks for reporting upstream:
https://github.com/openSUSE/obs-service-source_validator/issues/34

I am not using this package myself ATM. I made you co-maintainer feel free to update in case you find a patch or a better version.

fusion809 commented on 2016-03-09 13:37

Running osc build Arch_Extra and osc ci -m "Updating" both return similar errors which seem to be related to this package. This is the error:

Run source service: /usr/lib/obs/service/download_files --outdir /tmp/tmpheyZKX
Run source service: /usr/lib/obs/service/format_spec_file --outdir /tmp/tmpaLf1dJ
Run source service: /usr/lib/obs/service/source_validator --outdir /tmp/tmpVU2SMw
(W) Attention, gvim.install is not mentioned in spec files as source or patch.
###ASK /home/fusion809/OBS/home:fusion809/vim/gvim.install
- package has vim-7.4-rpmlintrc: (unchanged)
changelog not in sequence:
Mon Feb 8 13:22:33 UTC 2016 - idonmez@suse.com
* Mon Feb 08 2016 idonmez@suse.com
- Updated to revision 1294, fixes the following problems
* copy() and deepcopy() fail with special variables.
* Encoding {'key':} to JSON doesn't give an error.
* assert_false(v:false) reports an error.
* When jsonencode() fails it still returns something.
* jsonencode() is not producing strict JSON.
* Crash when evaluating the pattern of ":catch" causes an error.
* The job feature isn't available on MS-Windows.
* ch_open() with a timeout doesn't work correctly.
* ch_sendexpr() does not use JS encoding.
- Temporarily disable vim-7.3-diff_check.patch
=======
- Updated to revision 1294, fixes the following problems
* copy() and deepcopy() fail with special variables.
* Encoding {'key':} to JSON doesn't give an error.
* assert_false(v:false) reports an error.
* When jsonencode() fails it still returns something.
* jsonencode() is not producing strict JSON.
* Crash when evaluating the pattern of ":catch" causes an error.
* The job feature isn't available on MS-Windows.
* ch_open() with a timeout doesn't work correctly.
* ch_sendexpr() does not use JS encoding.
- Remove vim-7.3-diff_check.patch
>>>>>>> .new

Tue Feb 16 09:57:19 UTC 2016 - idonmez@suse.com
* Tue Feb 16 2016 idonmez@suse.com
- Updated to revision 1328, fixes the following problems
* Cursor changes column with up motion when the matchparen
plugin saves and restores the cursor position. (Martin Kunev)
* "\%%1l^#.*" does not match on a line starting with "#".
* Channel with pipes doesn't work in GUI.
* Crash when unletting the variable that holds the channel
in a callback function.
* Can't compile with +job but without +channel.

Please fix with your own tools or try /usr/lib/obs/service/source_validators/helpers/fix_changelog
Aborting: service call failed: /usr/lib/obs/service/source_validator --outdir /tmp/tmpVU2SMw
Source service run failed!

Building this package by running sudo make install DESTDIR= in the git repo https://github.com/openSUSE/obs-service-source_validator, causes the same error to arise when running these actions.

JonnyJD commented on 2015-04-03 10:08

thx, updated

c-mauderer commented on 2015-04-02 18:44

The sorces have been updated to 0.5-3.1. See http://download.opensuse.org/source/factory/repo/oss/suse/src/obs-service-source_validator-0.5-3.1.src.rpm.mirrorlist

JonnyJD commented on 2014-08-20 23:28

Thanks updated.

pnorcks commented on 2014-08-20 22:31

The latest srpm has build number 2.1

JonnyJD commented on 2014-07-22 23:01

thx, updated

BM-arch commented on 2014-07-22 19:57

There is a newer version available.

The following thins changed:

pkgver=0.3 => pkgver=0.4
_pkgrel=6.2 => _pkgrel=1.1
md5sums=('9e014e8ad41f642135cb4a74bc421e5d') => md5sums=('1f0d45a5496229ae6c366860ac04d48b')

But please verify by yourself.

JonnyJD commented on 2014-04-04 16:57

This depends on libxml2 now for xmllint.

Nothing4You commented on 2014-04-04 16:36

_pkgrel=6.2
md5sums=('9e014e8ad41f642135cb4a74bc421e5d')

Nothing4You commented on 2014-04-04 16:33

Upstream 404s

JonnyJD commented on 2013-11-03 14:09

Thanks updated (both packages) The old url schema still works, but I also updated that, since it is obviously deprecated.

c-mauderer commented on 2013-11-03 10:56

It seems, that the source URL and the version has changed to http://download.opensuse.org/source/factory/repo/oss/suse/src/obs-service-source_validator-0.3-5.3.src.rpm

JonnyJD commented on 2013-02-12 16:20

This is now provided by https://aur.archlinux.org/packages/obs-service-source_validator