Package Details: ocaml-curses 1.0.11-4

Git Clone URL: https://aur.archlinux.org/ocaml-curses.git (read-only, click to copy)
Package Base: ocaml-curses
Description: Objective Caml libs for curses
Upstream URL: https://github.com/mbacarella/curses
Licenses: LGPL
Submitter: oriba
Maintainer: Perdu
Last Packager: Perdu
Votes: 1
Popularity: 0.073791
First Submitted: 2015-08-09 13:16 (UTC)
Last Updated: 2024-06-04 10:30 (UTC)

Latest Comments

1 2 Next › Last »

Perdu commented on 2024-06-04 10:30 (UTC)

@meadow: thanks, done

meadow commented on 2024-06-03 13:31 (UTC) (edited on 2024-06-03 13:31 (UTC) by meadow)

@Perdu: Packages in extra bump their pkgrel when recompiling is required. Of course you can build manually but it's nicer if one doesn't have to :)

Examples:

https://gitlab.archlinux.org/archlinux/packaging/packages/ocaml-ctypes/-/commit/d8153a6f0f8f2a3fbeca8cfb92dcec28980864d3

https://archlinux.org/todo/rebuild-packages-against-gcc-13-to-circumvent-issues-with-lto/

Perdu commented on 2024-06-03 09:02 (UTC)

@meadow: I think you have to/can manually rebuild in such case? Or am I missing something? I often have this issue with python libs and just run yay -S again (but if there are best practices explaining this somewhere, I'd be eager to know)

meadow commented on 2024-06-02 16:01 (UTC)

Hey,

Could you bump the pkgver by one to force a rebuild for Ocaml 5.2? :)

Background: Some of my packages don't build because they need ocaml-curses built with the same Ocaml version.

Thanks!

oriba commented on 2023-11-20 16:12 (UTC)

The frantic adoption of dune was wrong from the very beginning. I know some libaries that can't be compiled to new versions because of dune-problems.

Perdu commented on 2023-11-20 15:42 (UTC)

@TTimo: well, it works on a fresh install on my side. I don't know dune enough to help you further. It may have a cache system that can be cleaned?

Perdu commented on 2023-10-17 14:54 (UTC)

@micwoj92: updated

micwoj92 commented on 2023-10-16 21:35 (UTC)

Needs ncurses+glibc in depends.

Perdu commented on 2023-09-14 14:41 (UTC)

@TTimo: install works on a fresh arch image (https://gitlab.com/wyrd-calendar/wyrd/-/jobs/5089747368). Are you up-to-date and tested a clean build?