Package Details: ocaml-extlib 1.7.6-1

Git Clone URL: https://aur.archlinux.org/ocaml-extlib.git (read-only)
Package Base: ocaml-extlib
Description: Extends the OCaml standard library
Upstream URL: https://github.com/ygrek/ocaml-extlib
Licenses: LGPL
Submitter: tahayassen
Maintainer: nerflad
Last Packager: nerflad
Votes: 36
Popularity: 0.258247
First Submitted: 2015-08-25 21:31
Last Updated: 2019-05-25 02:04

Latest Comments

1 2 Next › Last »

nerflad commented on 2017-10-16 01:08

@dun: cppo: command not found, this was a result of a bad update to the cppo package, which I adopted today and fixed. This package should be building properly now.

dun commented on 2017-10-15 15:16

I get this during the build:

==> Starting build()...
fatal: Not a git repository: '.git'
make -C src build
make[1]: Entering directory '/home/dun/ocaml-extlib/src/ocaml-extlib-1.7.2/src'
ocamlfind ocamlc -pp "cppo -D OCAML4 -D OCAML4_02 -D OCAML4_03 -D OCAML4_04 -D OCAML4_05 -D WITH_BYTES" -g -package bytes -i extBytes.ml > extBytes.mli
sh: cppo: command not found
File "extBytes.ml", line 1:
Error: Error while running external preprocessor
Command line: cppo -D OCAML4 -D OCAML4_02 -D OCAML4_03 -D OCAML4_04 -D OCAML4_05 -D WITH_BYTES 'extBytes.ml' > /tmp/ocamlpp2dd324

make[1]: *** [Makefile:53: extBytes.mli] Error 2
make[1]: Leaving directory '/home/dun/ocaml-extlib/src/ocaml-extlib-1.7.2/src'
make: *** [Makefile:14: build] Error 2
==> ERROR: A failure occurred in build().
Aborting...

nerflad commented on 2017-09-30 19:25

@radek_r done. Thank you.

radek_r commented on 2017-09-30 12:07

Please add achitecture "armv7h" to the PKGBUILD.

nerflad commented on 2017-06-04 18:20

Adopted. Please comment with any issues

yan12125 commented on 2017-06-03 10:09

I adopted this as I needed google-drive-ocamlfuse. Now I've turned to rclone, so I'll disown this. Feel free to adopt it.

yan12125 commented on 2016-11-15 18:32

Upgraded to 1.7.1. I've changed PKGBUILD a lot by general knowledge of Arch packaging. However, I know nothing about OCaml, so please report problems if any.

yan12125 commented on 2016-01-09 11:37

Adopted and fixed all problems.

lesebas commented on 2016-01-09 08:10

Hello,

Package disowned, I don't have time to maintain it.

JP-Ellis commented on 2016-01-09 04:00

Could you please update the PKGBUILD so that the options are:

```
options=('staticlibs' '!makeflags')
```

since this package (at this stage) does not support compilation in parallel. This prevents '-jN' from being used by makepkg.