Package Details: ocaml-lwt 2.5.2-1

Git Clone URL: https://aur.archlinux.org/ocaml-lwt.git (read-only)
Package Base: ocaml-lwt
Description: A library for cooperative threads in OCaml
Upstream URL: http://ocsigen.org/lwt/
Licenses: LGPL
Submitter: SerP
Maintainer: J5lx
Last Packager: J5lx
Votes: 13
Popularity: 0.055334
First Submitted: 2010-07-22 14:30
Last Updated: 2016-06-21 16:35

Latest Comments

J5lx commented on 2015-05-13 13:34

I added it to the configure line. Thanks for the notice!

talex commented on 2015-05-13 10:03

I think this package should now be compiled with --enable-camlp4 too (needed since 2.4.4). See: https://aur.archlinux.org/packages/zeroinstall-injector/

cormac-obrien commented on 2014-11-12 22:22

Not 100% sure, but this package appears to be out of date.

E: Cannot find findlib package camlp4
E: Cannot find findlib package camlp4.extend
E: Cannot find findlib package camlp4.quotations.o
E: Failure("3 configuration errors")
==> ERROR: A failure occurred in build().
Aborting...

I have ocaml-findlib and camlp4 installed from the official repos.

talex commented on 2014-05-24 11:10

Lwt 2.4.4 (and 2.4.5) have now been released, which should fix these problems:

https://github.com/ocsigen/lwt/releases

bcdarwin commented on 2014-02-02 04:55

Ocaml-lwt < 2.4.4 won't build with ocaml >= 4.01, so this package should add 'ocaml <= 4.00' to `depends`. This will be resolved when 2.4.4 is released.

In the meantime, I've released an ocaml-lwt-git package providing ocaml-lwt.

kozec commented on 2014-01-22 11:27

Build fails on my machine: http://pastebin.com/JnmeJ6HN

ftrvxmtrx commented on 2012-10-05 13:34

Thanks, fixed.
Updated to 2.4.2 as well.

noddy commented on 2012-09-16 02:41

2.4.1-1 needs a little fix with Ocaml 4.00.0:


--- PKGBUILD.old 2012-09-16 04:39:09.349377519 +0200
+++ PKGBUILD 2012-09-16 04:39:24.846065206 +0200
@@ -19,6 +19,8 @@
build() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"

+ echo '<src/top/*.*>: use_compiler_libs' >> _tags
+
# What requires what?
# --enable-glib glibc
# --enable-react ocaml-react

Anonymous comment on 2011-09-18 17:40

Updated :)

zorun commented on 2011-09-18 17:18

The compiler libraries are now available as the "ocaml-compiler-libs" package in [extra].

Could you update the dependencies to reflect the change? Thank you!

Anonymous comment on 2011-09-16 20:31

Updated PKGBUILD -- *all* lwt features are now installed by default.

zorun commented on 2011-08-26 18:25

Actually, it depends on some ocaml internal libs, usually provided by an `ocaml-compiler-libs` package (although such a dependency is not stated in the README...) because toplevel-related stuff are internal to the ocaml compiler.

It would be alot easier if these libs were integrated in the `ocaml` package, see https://bugs.archlinux.org/task/25763

Anonymous comment on 2011-08-26 17:49

I wonder how lwt folks build it, since that Types module is clearly missing <_<

zorun commented on 2011-08-26 02:47

Ok, as a quick hack, it compiles fine without `--enable-toplevel`... And ocaml-utop seems happy anyway.

Here is an updated PKGBUILD: http://pastebin.archlinux.fr/433720

zorun commented on 2011-08-25 14:30

@superbobry: with your updated PKGBUILD (which is needed for `ocaml-lambda-term`), Lwt doesn't compile anymore. It starts well, but after a moment it fails: http://pastebin.archlinux.fr/433705

Please note that it is *not* the same error as the one you would get by not installing react.o from `ocaml-react`.

Since nothing has changed since one week ago, I see multiple reasons for it to fail:
* an error in the PKGBUILD you've pasted (but I see nothing wrong);
* the recent modification of "CFLAGS", "CXXFLAGS" and "LDFLAGS" in /etc/makepkg.conf might have broken something;
* the error ("Error: Unbound module Types") suggests that there might be a missing dependency;
* I've got a lot of warnings about `/usr/lib/ocaml/site-lib` not existing; this is weird, I've never seen that before.

I'll try to investigate, but I don't quite see what's wrong...

Anonymous comment on 2011-08-17 08:35

Why won't you enable *at least* React helpers and enhanced toplevel -- the package depends on ocaml-react anyway? http://pastebin.com/XJ0TrZ4p

SerP commented on 2011-05-25 19:43

updated to latest

Anonymous comment on 2011-02-28 16:51

update to latest.

Anonymous comment on 2011-02-28 16:51

srcname=lwt
pkgname="ocaml-$srcname"
pkgver=2.2.1
pkgrel=1
pkgdesc="A library for cooperative threads in OCaml"
arch=('i686' 'x86_64')
url="http://ocsigen.org/lwt/"
license=('LGPL')
depends=('ocaml>=3.11.0' 'ocaml-findlib' 'react' 'libev')
source=(http://ocsigen.org/download/$srcname-$pkgver.tar.gz)
md5sums=('749546032f4fdd686d4b5dc7ecdf30ac')
conflicts=('lwt')

build() {
cd $srcdir/$srcname-$pkgver

mkdir -p "$pkgdir/$(ocamlfind printconf destdir)"
mkdir -p "$pkgdir/$(ocamlfind printconf destdir)/stublibs"
env DESTDIR="$pkgdir" \
OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
make
env DESTDIR="$pkgdir" \
OCAMLFIND_DESTDIR="$pkgdir/$(ocamlfind printconf destdir)" \
make install
install -Dm 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}