Package Details: ocaml-ppx_deriving 4.2.1-1

Git Clone URL: (read-only)
Package Base: ocaml-ppx_deriving
Description: Type-driven code generation for OCaml >=4.02
Upstream URL:
Licenses: MIT
Submitter: J5lx
Maintainer: J5lx
Last Packager: J5lx
Votes: 1
Popularity: 0.000000
First Submitted: 2016-02-06 01:59
Last Updated: 2018-06-27 19:26

Latest Comments

catalin.hritcu commented on 2018-10-06 15:02

@J5lx Many thanks for the help. Rebuilding cppo indeed helped with getting ocaml-ppx_deriving to build. For future reference, here are the magic commands I needed to run to get the cppo PKGBUILD and then install from that:

$ git clone --single-branch -b packages/cppo
$ cd community/repos/community-x86_64
$ makepkg
$ pacman -U cppo-1.6.4-1-x86_64.pkg.tar.xz

J5lx commented on 2018-10-06 14:12

Sorry for the wait. This package does support OCaml 4.07, however, as suggested by the error message you got, the current cppo package in community has not yet been compiled against that version of OCaml, causing the compilation of this package to fail. I have reported this issue on the Arch bug tracker, see FS#60325 for the current status. Once that issue gets fixed, this package should build again. In the meantime, you can attempt to recompile cppo yourself, however be aware that the installation routine is seemingly out-of-date and broken right now after changes in the dune build system.

catalin.hritcu commented on 2018-09-07 08:40

Or could it be that this package doesn't yet support OCaml 4.07.0? It's the default in arch now, and does seem supported by ppx_deriving on opam:

catalin.hritcu commented on 2018-09-07 08:21

Probably something is messed up on my system, since I'm getting the following error when trying to build:

+ ocamlfind ocamlopt -package unix -package ocamlbuild -linkpkg -package cppo_ocamlbuild /usr/lib/ocaml/ocamlbuild/ocamlbuild.cmx -o myocamlbuild
File "", line 1:
Error: /usr/lib/ocaml/cppo_ocamlbuild/ocamlbuild_cppo.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.

I'm using the default ocaml-4.07.0-1, ocamlbuild-0.12.0-3, and cppo-1.6.4-1 packages. Any advice?