Package Details: ocamlfuse 2.7.1-6

Git Clone URL: (read-only)
Package Base: ocamlfuse
Description: An ocaml binding for fuse.
Upstream URL:
Licenses: GPL2
Submitter: hobarrera
Maintainer: jkl
Last Packager: jkl
Votes: 15
Popularity: 0.495091
First Submitted: 2013-08-20 05:04
Last Updated: 2016-06-03 22:33

Latest Comments

Buddlespit commented on 2016-10-01 00:39
is now

hexchain commented on 2016-06-04 05:22

Thanks! Tried building google-drive-ocamlfuse and it worked great!

jkl commented on 2016-06-03 22:37

@hexchain Try it now, let me know if it works.

hexchain commented on 2016-06-01 14:57

Coming from google-drive-ocamlfuse...
It seems like "ocamlfind query" does not search for /usr/lib/ocaml/site-lib, so that package fails to compile. Removing "site-lib" segment from paths in package() seems to solve the problem.

liambluebox commented on 2016-03-03 05:24

Any idea why I'm getting this error:
==> Extracting sources...
-> Extracting ocamlfuse-2.7.1_cvs2.tar.gz with bsdtar
==> Starting build()...
camlidl -header \
Fatal error: the file '/usr/bin/camlidl' is not a bytecode executable file
../OCamlMakefile:1008: recipe for target 'Fuse_bindings.mli' failed
make: *** [Fuse_bindings.mli] Error 2
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build ocamlfuse.

lesebas commented on 2015-10-08 06:43

The SSL certificat have been updated, it works fine now!

lesebas commented on 2015-10-07 06:53

I can't download the archive :

0 0 0 0 0 0 0 0 --:--:-- --:--:--
--:--:-- 0curl: (60) SSL certificate problem: certificate has expired
More details here:


==> ERREUR : Erreur lors du téléchargement de ocamlfuse-2.7.1_cvs2.tar.gz

Maybe it could be simpler to use the following URL which don't intergrate any certificate :

Edit : I manage to rebuilt it by dowloading the package from my webbrowser and copying it manualy in the temp package directory.

jkl commented on 2015-03-12 16:37

Yep, ocaml packages outside of opam don't really work with pacman since there is no way to coordinate everyone maintaining the releases in step with ABI compatibility. Either assume you have to rebuild almost everything when ocaml changes, or use opam.
There was a minor "cvs2" update so I have applied that.

Nowaker commented on 2015-03-11 20:49

Okay, I rebeuilt ocaml-curl and now it works.

Nowaker commented on 2015-03-11 20:45

Doesn't build.

All comments