Package Details: ocropy-git 737.8b88583-1

Git Clone URL: https://aur.archlinux.org/ocropy-git.git (read-only)
Package Base: ocropy-git
Description: Python-based OCR package using recurrent neural networks (formerly ocropus)
Upstream URL: https://github.com/tmbdev/ocropy
Licenses: Apache
Conflicts: ocropy
Provides: ocropy
Submitter: stativ
Maintainer: stativ
Last Packager: stativ
Votes: 12
Popularity: 0.000000
First Submitted: 2015-02-22 20:53
Last Updated: 2015-06-20 14:58

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Anonymous comment on 2011-12-15 09:20

Thanks for the suggestions. I'll try to figure out what models work and install only them.
At least default.cmodel should work.

chenxiaolong commented on 2011-12-14 17:52

@solstice: Could you post your PKGBUILD at a site, like http://pastie.org ? I'll see if I can get it working.

solstice commented on 2011-12-14 15:05

I am trying to follow http://www.youtube.com/watch?v=pDYq0MlD8RQ&list=PL0B3367BC0E5CAF8D
but I can't run ocropus-lattices because there is no model installed

I modified the PKGBUILD to install ocropy/models
Now it complains not finding them because it looks in /usr/local/share...
I changed /usr/lib/python2.7/site-packages/ocrolib/common.py to look into /usr/share instead
now it tries to load ocropus module that does not exist !!

I give up!

Is anyone using this thing ? the maintainer ? how ?

solstice commented on 2011-12-14 14:25

python2-matplotlib and python2-scipy are needed as dependancies
and python2 is not needed as a dep because all python2-* package will bring up that dependancy

solstice commented on 2011-12-14 14:24

python2-matplotlib and python2-scipy are needed deps

chenxiaolong commented on 2011-10-18 19:56

Works perfectly now :D Thank you!

Anonymous comment on 2011-10-18 18:01

OK, I think I fixed that. Thank you for catching it and for the dependencies.
Could you please try this version?

chenxiaolong commented on 2011-10-18 17:43

Hmmm...it needs iulib to compile, but the package also contains files from iulib.

chenxiaolong commented on 2011-10-18 17:13

Could you please add python2-numpy and sdl_gfx to the dependencies?

Also, why is iulib-hg in the conflicts array? I get the following error about missing iulib when compiling:

AssertionError: :
File "/tmp/yaourt-tmp-chenxiaolong/aur-ocropus-hg/src/ocropus-build/ocrofst/SConstruct", line 106:
assert conf.CheckLibWithHeader("iulib","iulib/iulib.h","C++");

Anonymous comment on 2011-10-14 00:34

Updated after the big reorganization of 9 Oct 2011 (https://groups.google.com/group/ocropus/browse_thread/thread/8a19d72553649c99)

All the ocropus subprojects are now in subrepos. This probably will result in havoc since makepkg sees only the main repo's version. As the result, the version dropped from 300+ to 14, but this is not the worst problem. The worst is that the version won't bump when subrepos update.

Almost all of the weird packages (iulib, ocroswig, ocropy, ocrofst) are now obsolete. It doesn't make sense to track ocropus internal structure with Arch's packaging system. The only separate package remaining is pyopenfst.

Some stuff that this package installs doesn't work. The interesting commands are ocropus-{binarize,pseg,lattice,align,hocr}.