Package Details: octave-data-smoothing 1.3.0-2

Git Clone URL: https://aur.archlinux.org/octave-data-smoothing.git (read-only)
Package Base: octave-data-smoothing
Description: Algorithms for smoothing noisy data
Upstream URL: http://octave.sourceforge.net/data-smoothing/
Licenses: GPL3
Groups: octave-forge
Submitter: drizzd
Maintainer: drizzd (wangjiezhe)
Last Packager: drizzd
Votes: 10
Popularity: 0.000827
First Submitted: 2012-03-11 10:33
Last Updated: 2015-06-10 09:16

Dependencies (2)

Required by (0)

Sources (1)

Latest Comments

drizzd commented on 2014-03-16 13:42

I have updated all my octave-forge packages to work around the uninstall bug.

drizzd commented on 2014-03-09 17:04

FWIW, here's a bug report for the database wipe: https://savannah.gnu.org/bugs/index.php?41812

drizzd commented on 2014-03-03 14:51

Please give me the output of "pkg list" on the octave command prompt. I need this information to determine your situation.

I think that some of your packages are installed in pacman, but not in octave. This happens if pkg install fails, because it is called during post-install. At that point it is too late for pacman to roll back. It also happens if one pkg uninstall's a package while running octave as root. That way I can reproduce your original issue.

Furthermore, it seems that removing such an incomplete package causes a complete wipe of the octave package database. So watch your pkg list and remove all packages before re-installing any.

hal commented on 2014-03-03 09:22

Well, I followed your recommendation, and this is what i've got.

octave-optim
makepkg -s -i -f

untar (/usr/share/octave/optim.tar.gz, /tmp/oct-CSNr4U)
error: the following dependencies were unsatisfied:
optim needs miscellaneous >= 1.0.10
optim needs struct >= 1.0.10
optim needs parallel >= 2.0.5
error: command failed to execute correctly

octave-struct, octave-parallel reinstall went fine

octave-miscellaneous
mkdir (/tmp/oct-D9vy4g)
untar (/usr/share/octave/miscellaneous.tar.gz, /tmp/oct-D9vy4g)
error: the following dependencies were unsatisfied:
miscellaneous needs general >= 1.3.1
error: command failed to execute correctly

octave-general reinstall went fine

and then back to octave-miscellaneous

error: the following dependencies were unsatisfied:
miscellaneous needs general >= 1.3.1
error: command failed to execute correctly

hal commented on 2014-03-03 09:21

Well, I followed your recommendation, and this what i've got.

octave-optim
makepkg -s -i -f

untar (/usr/share/octave/optim.tar.gz, /tmp/oct-CSNr4U)
error: the following dependencies were unsatisfied:
optim needs miscellaneous >= 1.0.10
optim needs struct >= 1.0.10
optim needs parallel >= 2.0.5
error: command failed to execute correctly

octave-struct, octave-parallel reinstall went fine

octave-miscellaneous
mkdir (/tmp/oct-D9vy4g)
untar (/usr/share/octave/miscellaneous.tar.gz, /tmp/oct-D9vy4g)
error: the following dependencies were unsatisfied:
miscellaneous needs general >= 1.3.1
error: command failed to execute correctly

octave-general reinstall went fine

and then back to octave-miscellaneous

error: the following dependencies were unsatisfied:
miscellaneous needs general >= 1.3.1
error: command failed to execute correctly


drizzd commented on 2014-02-28 10:02

Sounds like octave-optim did not install correctly. Is it listed in the output of "pkg list"? Does "pkg load optim" run without error? Please re-build and re-install octave-optim with makepkg -s -i -f and watch the output for errors. Maybe also disable any MAKEFLAGS you might have configured in /etc/makepkg.conf.

hal commented on 2014-02-26 13:07

Hello!

there is a build error (x86_64, multilib)
(optim installed, local/octave-optim 1.3.0-1)

mkdir (/tmp/oct-K6441f)
untar (/usr/share/octave/data-smoothing.tar.gz, /tmp/oct-K6441f)
error: the following dependencies were unsatisfied:
data-smoothing needs optim >= 1.0.3
error: command failed to execute correctly

hal commented on 2014-02-26 13:05

Hello!

there is a build error (x86_64, multilib)

mkdir (/tmp/oct-K6441f)
untar (/usr/share/octave/data-smoothing.tar.gz, /tmp/oct-K6441f)
error: the following dependencies were unsatisfied:
data-smoothing needs optim >= 1.0.3
error: command failed to execute correctly