Package Details: octave-hg 4.1.0+21659.ff2347e1df02-1

Git Clone URL: https://aur.archlinux.org/octave-hg.git (read-only)
Package Base: octave-hg
Description: A high-level language, primarily intended for numerical computations.
Upstream URL: http://www.octave.org
Licenses: GPL
Conflicts: octave
Provides: octave=4.1.0
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 7
Popularity: 0.004645
First Submitted: 2009-10-01 23:27
Last Updated: 2016-04-29 22:43

Required by (85)

Sources (1)

  • java-slackware.patch

Latest Comments

haawda commented on 2016-02-05 16:15

Strange, /usr/lib/jvm/java-8-openjdk/jre/include should be there, if java-environment is installed. And that group _is_ in the deps.

fusion809 commented on 2016-02-05 01:56

Hi, I just tried to build this package and it returned this error:

g++: error: /usr/lib/jvm/java-8-openjdk/jre/include: No such file or directory
g++: error: /usr/lib/jvm/java-8-openjdk/jre/include: No such file or directory
Makefile:27278: recipe for target 'libinterp/octave-value/ov-class.df' failed
make: *** [libinterp/octave-value/ov-class.df] Error 1

maybe a missing Java-related dependency?

haawda commented on 2015-12-30 19:55

Great fix! Works fine.

I am currently tring to get jit working. If that fails, I will upload your fix only.

flipmess commented on 2015-12-29 22:05

hi
after your change:
- --with-java-libdir=/usr/lib/jvm/`archlinux-java get`/lib/${_arch}/server
+ --with-java-libdir=/usr/lib/jvm/`archlinux-java get`/lib/${_arch}/server:/usr/lib/jvm/`archlinux-java get`/jre/lib/${_arch}/server

i still get:
Build Java interface: no

if i change it to:
--with-java-libdir={/usr/lib/jvm/`archlinux-java get`/lib/${_arch}/server,/usr/lib/jvm/`archlinux-java get`/jre/lib/${_arch}/server}

i get:
Build Java interface: yes

thx for your work.

flipmess commented on 2015-11-28 00:01

it's working since you hardcoded "provides" to 4.1.0. thx.

flipmess commented on 2015-11-25 22:07

when i check the compiled packages they say:
Name : octave-hg
Version : 4.1.0+20749.74cc8ae4e2b0-1
Description : A high-level language, primarily intended for numerical computations.
Architecture : x86_64
URL : http://www.octave.org
Licenses : GPL
Groups : None
Provides : octave=
Depends On : fftw>=3.2.2 curl...

so maybe the problem is with "Provides : octave="

flipmess commented on 2015-11-25 16:57

i get the same error unfortunately. but it compiles fine...

something i've notced; you reverted the change about java libs:
--with-java-libdir=/usr/lib/jvm/`archlinux-java get`/jre/lib/${_arch}/server
back to
--with-java-libdir=/usr/lib/jvm/`archlinux-java get`/lib/${_arch}/server
so it can't find them. at least on my system ^^;

there are also many errors when generating docs when pstoedit is missing.

also due to !makeflags you are inhibiting -j8 for example, but it compiles fine on multiple cpus so the compile time is drastically reduced when using -j8. i don't know about other makeflags.

thx

haawda commented on 2015-11-25 07:31

I removed the + in provides. Does it help?

flipmess commented on 2015-11-25 00:55

ever since there is a "+" in the version i can't update. it's just an observation. shouldn't it be providing ver 4.1.0?

looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: octave-control: requires octave>=3.8.0
:: octave-general: requires octave>=4.0.0
:: octave-linear-algebra: requires octave>=3.2.3
:: octave-signal: requires octave>=3.8.0
...
ERROR: unable to update

flipmess commented on 2015-08-12 15:30

i think you should remove www. from http://www.octave.org
than it redirects correctly...

All comments