Package Details: octave-hg 6:8.0.0.r31096.b6aeea949531-1

Git Clone URL: https://aur.archlinux.org/octave-hg.git (read-only, click to copy)
Package Base: octave-hg
Description: A high-level language, primarily intended for numerical computations.
Upstream URL: http://www.octave.org
Licenses: GPL
Conflicts: octave
Provides: octave
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 10
Popularity: 0.002433
First Submitted: 2009-10-01 23:27 (UTC)
Last Updated: 2022-06-15 21:50 (UTC)

Latest Comments

1 2 3 4 5 6 .. 11 Next › Last »

haawda commented on 2019-01-28 05:20 (UTC)

Upstream often changes main version between 6.0.0, 5.0.1 and now 5.0.90, causing epoch raises.

killpinguin commented on 2017-11-11 04:59 (UTC) (edited on 2017-11-11 05:08 (UTC) by killpinguin)

How can I run makepkg twice? I'm using yaourt.. Edit: I think I know what you mean but it doesn't work either.. /tmp/yaourt-tmp-xxx/aur-octave-hg makepkg -si ==> Making package: octave-hg 4.3.0-1 (Sa 11. Nov 13:01:19 +08 2017) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Updating gnulib git repo... Fetching origin ==> Validating source files with md5sums... gnulib ... Skipped ==> Extracting sources... -> Creating working copy of gnulib git repo... Reset branch 'makepkg' ==> Starting pkgver()... ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version: /tmp/yaourt-tmp-xxx/aur-octave-hg makepkg -si ==> Making package: octave-hg 4.3.0-1 (Sa 11. Nov 13:04:25 +08 2017) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Updating gnulib git repo... Fetching origin ==> Validating source files with md5sums... gnulib ... Skipped ==> Extracting sources... -> Creating working copy of gnulib git repo... Reset branch 'makepkg' ==> Starting pkgver()... ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version:

haawda commented on 2017-11-10 20:11 (UTC)

I get that sometimes, too, and, odd as it is, running makepkg twice alway solved the thing for me.

killpinguin commented on 2017-11-10 18:03 (UTC)

Hi all, I'm getting the following error... could someone tell me how to resolve this? ==> Building and installing package ==> Making package: octave-hg 4.3.0+24222.7d1561c9ee48-1 (Sa 11. Nov 01:39:30 +08 2017) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Updating gnulib git repo... Fetching origin ==> Validating source files with md5sums... gnulib ... Skipped ==> Extracting sources... -> Creating working copy of gnulib git repo... Switched to a new branch 'makepkg' ==> Starting pkgver()... ==> ERROR: pkgver is not allowed to be empty. ==> ERROR: pkgver() generated an invalid version: ==> ERROR: Makepkg was unable to build octave-hg.

midgard commented on 2017-08-13 11:12 (UTC)

There are unquoted ${srcdir}s and ${pkgdir}s on lines 41, 42, 44 and 68 of the PKGBUILD.

haawda commented on 2017-03-19 01:18 (UTC)

No, even if qscintilla-qt5 is install it wn't be correctly detected by configure. See the upstream bug report.

flipmess commented on 2017-03-18 23:23 (UTC)

would i have to install qscintilla which isn't a dependency for it to compile?

haawda commented on 2017-03-17 23:28 (UTC) (edited on 2017-03-17 23:31 (UTC) by haawda)

flipmess, I got the same this morning. It is not only you. See also https://savannah.gnu.org/bugs/?50572

flipmess commented on 2017-03-17 13:50 (UTC)

anyone else getting this error with the latest build? CXX libgui/src/m-editor/libgui_src_libgui_src_la-file-editor.lo ../libgui/src/m-editor/file-editor.cc:2480:1: error: 'file_editor_tab_widget' has not been declared file_editor_tab_widget::mousePressEvent(QMouseEvent *me) ^~~~~~~~~~~~~~~~~~~~~~ ../libgui/src/m-editor/file-editor.cc:2480:41: error: variable or field 'mousePressEvent' declared void file_editor_tab_widget::mousePressEvent(QMouseEvent *me) ^~~~~~~~~~~ ../libgui/src/m-editor/file-editor.cc:2480:41: error: 'QMouseEvent' was not declared in this scope ../libgui/src/m-editor/file-editor.cc:2480:54: error: 'me' was not declared in this scope file_editor_tab_widget::mousePressEvent(QMouseEvent *me) ^~ make[2]: *** [Makefile:16834: libgui/src/m-editor/libgui_src_libgui_src_la-file-editor.lo] Error 1 make[2]: *** Waiting for unfinished jobs.... make[2]: Leaving directory '/tmp/yaourt-tmp-flipmess/aur-octave-hg/src/octave-local/build' make[1]: *** [Makefile:26270: all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-flipmess/aur-octave-hg/src/octave-local/build' make: *** [Makefile:10009: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build octave-hg. ==> Restart building octave-hg ? [y/N] ==> ----------------------------------

haawda commented on 2017-03-12 15:07 (UTC) (edited on 2017-03-12 15:08 (UTC) by haawda)

It is not "--without-OSMesa", but "-without-osmesa". Fixed.