Package Details: octave-specfun 1.1.0-7

Git Clone URL: https://aur.archlinux.org/octave-specfun.git (read-only, click to copy)
Package Base: octave-specfun
Description: Special functions including ellipitic functions, etc
Upstream URL: https://octave.sourceforge.io/specfun
Licenses: custom
Groups: octave-forge
Submitter: drizzd
Maintainer: carlosal1015
Last Packager: carlosal1015
Votes: 28
Popularity: 0.000042
First Submitted: 2011-10-31 15:26 (UTC)
Last Updated: 2022-02-10 02:23 (UTC)

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

drws commented on 2023-07-25 08:07 (UTC)

Does not build:

mkoctfile -s ellipj.cc
ellipj.cc: In function ‘octave_value_list Fellipj(const octave_value_list&, int)’:
ellipj.cc:189:15: error: ‘error_state’ was not declared in this scope; did you mean ‘error_t’?
  189 |         if (! error_state) {
      |               ^~~~~~~~~~~
      |               error_t
ellipj.cc:257:14: error: ‘error_state’ was not declared in this scope; did you mean ‘error_t’?
  257 |        if (! error_state) {
      |              ^~~~~~~~~~~
      |              error_t
make: *** [Makefile:4: ellipj.oct] Error 1

carlosal1015 commented on 2022-11-13 18:08 (UTC)

No errors from my side.

Rulatir commented on 2022-11-12 22:14 (UTC) (edited on 2022-11-12 22:15 (UTC) by Rulatir)

Building and installing this package seems to have no effect on the availability of the specfun package for Octave:

>> pkg load specfun
error: package specfun is not installed
error: called from
    load_packages at line 47 column 7
    pkg at line 632 column 7

I did restart Octave.

carlosal1015 commented on 2022-02-10 02:24 (UTC)

Thanks @Feakster, fixed now.

Feakster commented on 2021-04-05 11:08 (UTC)

I'm getting build errors when trying to install this:

error: pkg: error running 'make' for the specfun package.
error: called from
    configure_make at line 110 column 9
    install at line 196 column 7
    pkg at line 568 column 9

Errors from the output:

ellipj.cc:193:23: error: ‘class octave_value’ has no member named ‘is_real_type’; did you mean ‘is_int8_type’?
  193 |             if (u_arg.is_real_type ()) {  // u real
      |                       ^~~~~~~~~~~~
      |                       is_int8_type

[truncated]

ellipj.cc:268:22: error: ‘class octave_value’ has no member named ‘is_real_type’; did you mean ‘is_int8_type’?
  268 |            if (u_arg.is_real_type ()) {
      |                      ^~~~~~~~~~~~
      |                      is_int8_type

[truncated]

ellipj.cc:299:22: error: ‘class octave_value’ has no member named ‘is_real_type’; did you mean ‘is_int8_type’?
  299 |            if (u_arg.is_real_type ()) {  // u real matrix
      |                      ^~~~~~~~~~~~
      |                      is_int8_type

drizzd commented on 2015-06-10 08:51 (UTC)

Upgrading fails with conflicts How to fix: Uninstall the package and packages which depend on it with pacman -Rc <package>, then re-install the new version and packages which depend on it. See also https://bbs.archlinux.org/viewtopic.php?id=196909.