Package Details: octave-splines 1.3.2-2

Git Clone URL: https://aur.archlinux.org/octave-splines.git (read-only)
Package Base: octave-splines
Description: Additional spline functions.
Upstream URL: http://octave.sourceforge.net/splines/
Keywords: interpolation math octave octave-forge spline
Licenses: custom
Groups: octave-forge
Submitter: drizzd
Maintainer: MadPhysicist
Last Packager: MadPhysicist
Votes: 11
Popularity: 0.000029
First Submitted: 2012-03-12 21:52
Last Updated: 2017-06-29 04:20

Latest Comments

pingplug commented on 2017-05-26 06:58

please update this package
this one can not build with octave 4.0+

MadPhysicist commented on 2015-08-25 21:23

And now I got the install script working too.

MadPhysicist commented on 2015-08-25 21:11

Qscintilla is a problem for octave, not this package. There is no good reason for this package to depend on it. The issue is that Octave now has a GUI, which we do not need to build, so using 'octave-cli' instead of 'octave' fixes the problem much more elegantly.

MadPhysicist commented on 2015-08-25 21:09

The problem is with octave, not with this package. There is no good reason for qscintilla to be associated with this package in any way. I have fixed the problem here by using 'octave-cli' instead of 'octave'.

drizzd commented on 2015-08-25 17:26

This packagr does not depend on qscintilla, but octave does:
https://bugs.archlinux.org/task/45956

aphirst commented on 2015-08-25 09:49

As qscintilla is only an optional dependency of `octave` in the main repo, it probably ought be at least a Build Dep for this package.

aphirst commented on 2015-08-25 09:39

==> Starting build()...
/usr/lib/octave/4.0.0/exec/x86_64-unknown-linux-gnu/octave-gui: error while loading shared libraries: libqscintilla2.so.12: cannot open shared object file: No such file or directory