Package Details: ogrebullet-git r42.b3c4e1e-1

Git Clone URL: https://aur.archlinux.org/ogrebullet-git.git (read-only, click to copy)
Package Base: ogrebullet-git
Description: Bullet Physics wrapper for OGRE
Upstream URL: http://www.ogre3d.org/tikiwiki/OgreBullet
Licenses: LGPL
Conflicts: ogrebullet-svn
Provides: ogrebullet
Submitter: bwrsandman
Maintainer: bwrsandman
Last Packager: bwrsandman
Votes: 6
Popularity: 0.000000
First Submitted: 2013-05-16 04:00 (UTC)
Last Updated: 2015-12-17 00:38 (UTC)

Latest Comments

bwrsandman commented on 2015-12-17 00:39 (UTC)

Compile issue fixed by removing old patch.

nulldragon commented on 2015-12-16 03:55 (UTC) (edited on 2015-12-16 03:56 (UTC) by nulldragon)

Fails to build. /tmp/makepkg/ogrebullet-git/src/ogrebullet/Collisions/src/Utils/OgreBulletCollisionsMeshToShapeConverter.cpp:636:1: error: prototype for ‘OgreBulletCollisions::StaticMeshToShapeConverter::StaticMeshToShapeConverter(Ogre::Entity*, const Ogre::Matrix4&)’ does not match any in class ‘OgreBulletCollisions::StaticMeshToShapeConverter’

sftrytry commented on 2013-01-30 04:56 (UTC)

Due to API changes in latest bullet 2.8.1. We have to patch 3 files to make it work. According to "http://www.ogre3d.org/addonforums/viewtopic.php?f=12&t=29787&sid=0d9207f7553773c3a87e813a872c27db" Also sed -i 's\AM_CONFIG_HEADER\AC_CONFIG_HEADERS\' configure.ac.

commented on 2012-03-23 11:49 (UTC)

@qubodup thank you I've installed this package already;) At first time it fail because I haven't update openssl so that why it can't use svn checkout:)

qubodup commented on 2012-03-22 22:39 (UTC)

@megacyber: Looks like temporary downtime of the svn. Try again, please.

commented on 2012-03-22 21:51 (UTC)

I can't install:( it told me that ==> Determining latest svn revision... svn: E175002: Unable to connect to a repository at URL 'https://ogreaddons.svn.sourceforge.net/svnroot/ogreaddons/trunk/ogrebullet' svn: E175002: OPTIONS of 'https://ogreaddons.svn.sourceforge.net/svnroot/ogreaddons/trunk/ogrebullet': SSL handshake failed: SSL disabled due to library version mismatch (https://ogreaddons.svn.sourceforge.net) ==> Starting build()... ==> Starting Subversion checkout... svn: E175002: Unable to connect to a repository at URL 'https://ogreaddons.svn.sourceforge.net/svnroot/ogreaddons/trunk/ogrebullet' svn: E175002: OPTIONS of 'https://ogreaddons.svn.sourceforge.net/svnroot/ogreaddons/trunk/ogrebullet': SSL handshake failed: SSL disabled due to library version mismatch (https://ogreaddons.svn.sourceforge.net) ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build ogrebullet-svn.

spider-mario commented on 2011-08-12 14:48 (UTC)

This library is under the MIT license, not the LGPL.

qubodup commented on 2011-03-17 18:53 (UTC)

Kniyl: thanks a lot! I updated the package!

Kniyl commented on 2011-03-02 22:38 (UTC)

I had to add the line sed -i 's\"ConvexBuilder.h"\"ConvexDecomposition/ConvexBuilder.h"\' Collisions/src/Utils/OgreBulletCollisionsMeshToShapeConverter.cpp before make. Otherwise, it fails. Moreover, I couldn't compile Demos. So I also had to change the make command that became: make LDFLAGS="-lConvexDecomposition" || return 1 Hope that helps.