Package Details: olive-git continuous.r370.g19eabf28-1

Git Clone URL: https://aur.archlinux.org/olive-git.git (read-only, click to copy)
Package Base: olive-git
Description: Free non-linear video editor
Upstream URL: https://www.olivevideoeditor.org/
Keywords: editor video
Licenses: GPL3
Conflicts: olive
Provides: olive
Submitter: tecnotercio
Maintainer: tecnotercio
Last Packager: tecnotercio
Votes: 9
Popularity: 0.31
First Submitted: 2019-03-04 05:49
Last Updated: 2021-02-01 21:37

Latest Comments

1 2 Next › Last »

wcasanova commented on 2021-02-07 01:24

@tecnotercio Of course the problem is when you have other packages that need the openimageio version from the community repository, example blender, but I know it is not the fault of this package

tecnotercio commented on 2021-02-07 00:51

@wcasanova: Olive needs OpenColorIO and OpenImageIO in the latest versions.

For now, it is only possible to install them using the "git" versions of the libraries.

In the case of the "opencolorio-git" package, although the version in PKGBUILD is "1.0.8.r586...", the installed version is 2.0.

wcasanova commented on 2021-02-06 19:56

in community repo, opencolorio and openimageio, they are with version 2, but openimageio 2, depends on opencolorio1. the conflict is with OpenColorIO

tecnotercio commented on 2021-01-25 22:35

@ruestique: The Git version of Olive needs OpenColorIO 2.0. For now, the version available in Arch Linux is 1.1.1.

The "opencolorio-git" package had a problem with the build, which has already been solved.

ruestique commented on 2021-01-09 00:13

opencolorio-git will failed, opencolorio use instead

tecnotercio commented on 2020-11-22 17:07

@mikesbytes: PKGBUILD now depends on the "openimageio-git" package. This package installs the latest version of OpenColorIO (opencolorio-git).

mikesbytes commented on 2020-11-20 07:29

It appears that this currently fails to build due to the opencolorio version not being new enough with the following error.

CMake Error at /usr/share/cmake-3.18/Modules/FindPackageHandleStandardArgs.cmake:165 (message):
  Could NOT find OpenColorIO: Found unsuitable version "1.1.1", but required
  is at least "2.0.0" (found /usr/lib/libOpenColorIO.so)

Unfortunately it seems like it will be impossible to build and install unless you can somehow get OpenColorIO v2 working on your system without breaking something else.

LuciRose431 commented on 2020-08-02 16:39

i get this error you know how to fix it https://i.imgur.com/7lmK2IV.png this error does not occur with stable version

tecnotercio commented on 2020-08-01 22:43

@greve and @haawda: PKGBUILD updated with the current revision number.

haawda commented on 2020-07-28 17:46

greve this is because 0 < 970, so yay thinks it can be updated. Using an epoch and increase it from time to time could be a solution, but a better one would be to use a date in pkgver. Wiki tells how.