Package Details: olivia r815.2235bab-1

Git Clone URL: https://aur.archlinux.org/olivia.git (read-only, click to copy)
Package Base: olivia
Description: Elegant Cloud Music Player for Linux Desktop
Upstream URL: https://github.com/keshavbhatt/olivia
Licenses: MIT
Submitter: Bleuzen
Maintainer: Bleuzen
Last Packager: Bleuzen
Votes: 8
Popularity: 0.016960
First Submitted: 2019-04-08 17:25
Last Updated: 2020-04-14 18:01

Latest Comments

Bleuzen commented on 2020-04-14 18:04

@FabioLolix thanks for the hints, second and third point are changed now.

FabioLolix commented on 2020-04-14 08:52

  • This should have been uploaded as olivia-git since when you created it there weren't tagged release and don't have a stable releases cycle yet

  • git is missing in makedepends

  • qt5-tools is usually needed only as makedepends

  • please build your pkgbuilds in clean chroot before uploading to the AUR

Bleuzen commented on 2020-02-19 20:39

@yochananmarqos Well, this may be correct for released programs. But in olivias case, it is under heavy development and the last tag is already pretty old. I messaged the author and he said it is better to build from git master for now. This is also what the official snap package does currently. This is likely to change when there is a 1.0 release.

yochananmarqos commented on 2020-02-18 20:17

Please pull from the release tag:

_pkgver=1.0-beta
pkgver=${_pkgver//-/.}

source=("git+https://github.com/keshavbhatt/olivia.git#tag=v$_pkgver")

Submit a proper VCS package called olivia-git if you want to pull directly from master. See VCS package guidelines:

pkgver() {
  cd "$srcdir/${pkgname%-git}"
  git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
1.0.beta.r269.g98eadff-1

Bleuzen commented on 2019-12-30 17:01

@Rocky-IV Done.

Rocky-IV commented on 2019-12-30 01:58

Please add [qt5-webkit] as a dependency! Olivia will not compile/build unless [qt5-webkit] is installed as a dependency. (QT modules errors)