Package Details: oni 0.3.9-2

Git Clone URL: (read-only, click to copy)
Package Base: oni
Description: An IDE built around Neovim
Upstream URL:
Keywords: gui ide neovim vim
Licenses: MIT
Submitter: terlar
Maintainer: badosu (onivim, someguynamedmatt)
Last Packager: badosu
Votes: 30
Popularity: 0.000697
First Submitted: 2017-03-17 20:28 (UTC)
Last Updated: 2019-01-18 15:11 (UTC)

Latest Comments

1 2 3 Next › Last »

badosu commented on 2019-01-18 15:09 (UTC) (edited on 2019-01-18 15:10 (UTC) by badosu)

Implemented a workaround on the package for issues with neovim > 0.3.1, see:

If you had to downgrade neovim consider upgrading Oni and neovim.

badjware commented on 2018-09-13 18:13 (UTC)

I got the error /opt/oni/oni: error while loading shared libraries: cannot open shared object file: No such file or directory

Installing the package nss fixed the issue. Maybe it should be added as a dependency?

ybc37 commented on 2018-08-10 09:24 (UTC) (edited on 2018-08-10 09:25 (UTC) by ybc37)

I followed the example of Skype and used patchelf to make Oni use a local copy of glibc 2.27.

Seems to work, but I cannot guarantee, that everything works. Please use it with caution and at your own risk.

Here's the hack:

mkdir /opt/oni/glibc
cd /opt/oni/glibc
curl -O
tar xJf glibc-2.27-3-x86_64.pkg.tar.xz
patchelf --set-interpreter "/opt/oni/glibc/usr/lib/" ../oni
patchelf --set-rpath "/opt/oni:/opt/oni/glibc/usr/lib" ../oni

ybc37 commented on 2018-08-08 09:45 (UTC) (edited on 2018-08-08 09:56 (UTC) by ybc37)

Indeed, glibc 2.28 breaks Oni. Tested it by downgrading to glibc 2.27 and Oni start up again. Thanks for the hint!

I created an issue upstream:

Edit: Seems like other packages, like Signal and Skype, are also affected. Skype uses patchelf to link to glibc 2.27:

svenstaro commented on 2018-08-07 15:04 (UTC)

Most likely the new glibc upgrade.

ybc37 commented on 2018-08-07 14:38 (UTC) (edited on 2018-08-07 14:39 (UTC) by ybc37)

Hi! I experience a segfault when trying to start oni. I used oni for months and I don't know what caused it. It must be a package upgrade in the last days, but I'm not able to track it down (downgraded nodejs; rebuild oni,.. nothing helped).

  • Does anyone else experience this?

  • Not sure if I should report this upstream, as the oni version didn't change and worked until a few days ago. Has anyone an idea what the cause could be?

Any help is appreciated :) Thanks!

alxdb commented on 2018-06-17 10:58 (UTC)

You need to add gtk2 to the dependencies

fatalis commented on 2018-04-22 14:56 (UTC)

These packages can be added to optdepends for language server support: clang-tools-extra python-language-server go-langserver-git

SilverRainZ commented on 2018-04-09 14:59 (UTC)

This package is built from a binary and should be named as oni-bin.

mahmoudhossam commented on 2018-04-07 10:25 (UTC)

0.3.2 released