Package Details: onioncircuits 0.8-1

Git Clone URL: (read-only, click to copy)
Package Base: onioncircuits
Description: GTK application to display Tor circuits and streams
Upstream URL:
Licenses: GPL3
Submitter: proninyaroslav
Maintainer: adsun
Last Packager: adsun
Votes: 4
Popularity: 0.023214
First Submitted: 2016-03-07 16:50 (UTC)
Last Updated: 2023-09-06 21:26 (UTC)

Latest Comments

1 2 Next › Last »

adsun commented on 2023-05-10 13:36 (UTC)

@dreieck Fixed. Thanks for letting me know.

dreieck commented on 2023-05-05 18:43 (UTC)

I get the following build error:
error: Multiple top-level packages discovered in a flat-layout: ['po', 'apparmor'].:

==> Starting build()...
error: Multiple top-level packages discovered in a flat-layout: ['po', 'apparmor'].

To avoid accidental inclusion of unwanted files or directories,
setuptools will not proceed with this build.

If you are trying to create a single distribution with multiple packages
on purpose, you should not rely on automatic discovery.
Instead, consider the following options:

1. set up custom discovery (`find` directive with `include` or `exclude`)
2. use a `src-layout`
3. explicitly set `py_modules` or `packages` with a list of names

To find more information, look for "package discovery" on setuptools docs.
==> ERROR: A failure occurred in build().

lodopidolo commented on 2020-05-01 14:49 (UTC)

@adsun I had configured Tor Control Password, and it is prompted correctly from nyx, but not from onioncircuits.

adsun commented on 2020-05-01 12:51 (UTC)

@lodopidolo You need to setup a Tor Control password. Instructions for setting up Tor, including password, can be found here:

lodopidolo commented on 2020-05-01 12:09 (UTC) (edited on 2020-05-01 12:09 (UTC) by lodopidolo)

Hi, how to indicate password?

When I run it:

$ onioncircuits
Tor requires a password to authenticate
Tor requires a password to authenticate
Tor requires a password to authenticate
Tor requires a password to authenticate

but there isn't any prompt box.

ryuta commented on 2019-05-01 08:51 (UTC)

The same as fatmatt : replacing depends=('python>=3.4.2' 'python-gobject>=3.14.0' 'stem>=1.2.2' 'gobject-introspection' 'python-distutils-extra') with depends=('python>=3.4.2' 'python-gobject>=3.14.0' 'python-stem>=1.2.2' 'gobject-introspection' 'python-distutils-extra') work.

fatmatt commented on 2019-01-31 22:06 (UTC) (edited on 2019-01-31 22:10 (UTC) by fatmatt)

==> Error: Could not find all required packages:

stem>=1.2.2 (Wanted by: onioncircuits)

# pacman -Q stem

python-stem 1.7.1-1

mpento commented on 2018-06-29 00:13 (UTC)

Updated to v0.5

jo-shva commented on 2017-07-13 20:58 (UTC)

Here is a Pastebin for a working PKGBUILD as of July 13,2017. I also have an updated PKGBUILD for the 'debhelper-python' PKGBUILD, now it will all build and work real nice ;-) onioncircuits:

anoa commented on 2016-06-22 03:09 (UTC)

Anyone having trouble with this package while it's 0.4 edit PKGBUILD, change pkgver to 0.4 and sha256sum to be14d379cc8e924092f646ee83daf7770a4f1164be4d2f05a2d64bbaeaaaa932.