Package Details: onlyoffice-documentserver 5.2.2-1

Git Clone URL: https://aur.archlinux.org/onlyoffice-documentserver.git (read-only)
Package Base: onlyoffice-documentserver
Description: Online office suite comprising viewers and editors for texts, spreadsheets and presentations
Upstream URL: https://github.com/ONLYOFFICE/DocumentServer
Licenses: AGPL
Submitter: onny
Maintainer: onny
Last Packager: onny
Votes: 4
Popularity: 0.784894
First Submitted: 2017-07-20 08:47
Last Updated: 2018-10-08 20:46

Required by (0)

Sources (13)

Latest Comments

1 2 Next › Last »

VVL commented on 2018-10-12 12:40

I tried to compile it from 5 PCs - but same errors. Can anyone share builed package?

onny commented on 2018-10-08 15:58

@VVL Not sure about this error yet. Currently I used the precompiled AllFontsGen which seems to be linked to a different libunicode version. I'll try to get the own compiled version of AllFontsGen running but I guess the upstream code might need some fixes, see bug report here: https://github.com/ONLYOFFICE/DocumentServer/issues/377

VVL commented on 2018-10-03 19:52

After update to 5.2.0 got this error: /usr/share/webapps/onlyoffice/documentserver/server/tools/AllFontsGen: symbol lookup error: /usr/share/webapps/onlyoffice/documentserver/server/tools/AllFontsGen: undefined symbol: _ZN6NSFile14CUtf8Converter24GetUnicodeStringFromUTF8EPhl

Systemd services starts, but nextcloud cant connect to onlyoffice.

teamanx commented on 2018-05-09 21:30

Can this package be compiled on ARM?

VanCoding commented on 2017-12-18 09:29

@onny Ok, I've uploaded the log of the whole installation process here: https://www.file-upload.net/download-12874548/onlyoffice-documentserver-5.0.6-1-x86_64-build.log.html

But it's huge! I hope it is in any way helpful...

onny commented on 2017-12-15 21:01

@VanCoding: A build log or something similar would be helpful :)

VanCoding commented on 2017-12-15 00:07

@onny I've tried it on my computer at home now, and I get the same error. The computer has 16GB of RAM so I'm pretty sure that is not the problem. Let me know if I can provide you more info.

VanCoding commented on 2017-12-13 12:46

@onny thanks :) sadly, it still gives me the same error even though i have more than 10GB of available RAM. I'll try on another computer, to see if it's something related to my machine.

onny commented on 2017-12-12 16:48

thanks for the info @VanCoding. Check that you have enough memory, you need more than 10 GB! I also updated the package so you could give it a retry :)

VanCoding commented on 2017-12-12 12:13

It's currently not possible to install this due to errors when compiling. Let me know if it's not reproducible for you and you need mor info.