Package Details: oomox-git 1.13.3-1

Git Clone URL: https://aur.archlinux.org/oomox-git.git (read-only, click to copy)
Package Base: oomox-git
Description: The project packaging has been changed - please install 'themix-full-git' instead
Upstream URL: https://github.com/themix-project/oomox
Keywords: appearance archdroid flat-plat gnome-colors gtk gtk2 gtk3 hidpi numix
Licenses: GPL3
Submitter: actionless
Maintainer: actionless
Last Packager: actionless
Votes: 33
Popularity: 0.004772
First Submitted: 2016-04-12 18:21
Last Updated: 2020-05-18 07:11

Dependencies (1)

Required by (0)

Sources (0)

Latest Comments

1 2 3 Next › Last »

actionless commented on 2019-11-19 00:07

@optional_install that's because https://aur.archlinux.org/packages/python-pystache/ need to be updated for python 3.8

optional_install commented on 2019-11-18 21:45

Had problems installing with pikaur/yay with a straightforward

yay -S oomox-git

I recall successfully installing it a few months ago by typing the above and choosing the default options. But today when I did that, installation would abort. So here is what finally worked: choosing git options instead of the default ones (as I am using oomox-git). Not rocket science but hey that's the level I'm at.

Dump follows:

yay -S oomox-git

:: There are 2 providers available for python-pystache:
:: Repository AUR
    1) python-pystache 2) python-pystache-git Enter a number (default=1): 2

:: There are 4 providers available for resvg: :: Repository AUR 1) resvg 2) resvg-cairo 3) resvg-git 4) resvg-qt Enter a number (default=1):3

:: There are 3 providers available for cargo: :: Repository world 1) rust :: Repository extra 2) rust :: Repository community 3) rustup Enter a number (default=1): 1

That's it, and this time it installed without a snag.

Scindix commented on 2018-12-29 21:16

@actionless Thanks. That worked!

actionless commented on 2018-12-29 21:06

and hit d

Scindix commented on 2018-12-29 21:05

@actionless Wow! That was fast! Proceeding doesn't solve the issue though as the same error shows up again afterwards.

Maybe I should post the whole log:

:: Downloading the latest sources for a devel package oomox-git...
:: error: failed to retrieve latest dev sources:
==> Making package: oomox-git 1.9.0.2.r55.g459ed93a-1 (Sat 29 Dec 2018 22:03:21 CET)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
  -> Updating oomox git repo...
Fetching origin
  -> Updating oomox-gtk-theme git repo...
Fetching origin
  -> Updating materia-theme git repo...
Fetching origin
==> ERROR: /home/username/.cache/pikaur/build/oomox-git/arc-theme is not a clone of https://github.com/actionless/arc-theme.git
    Aborting...

Do you want to proceed? [y/N] y

:: Starting the build:
==> Making package: oomox-git 1.9.0.2.r55.g459ed93a-1 (Sat 29 Dec 2018 22:03:27 CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating oomox git repo...
Fetching origin
  -> Updating oomox-gtk-theme git repo...
Fetching origin
  -> Updating materia-theme git repo...
Fetching origin
==> ERROR: /home/username/.cache/pikaur/build/oomox-git/arc-theme is not a clone of https://github.com/actionless/arc-theme.git
    Aborting...

Command 'makepkg --force' failed to execute.
:: Try recovering?
[R] retry build
[p] PGP check skip
[c] checksums skip
[i] ignore architecture
[d] delete build dir and try again
------------------------
[s] skip building this package
[a] abort building all the packages
> 

actionless commented on 2018-12-29 20:58

@Scindix, branch should be resvg, in pikaur just hit y to proceed

Scindix commented on 2018-12-29 20:56

I couldn't update the package. It exits with the following error:

Fetching origin ==> ERROR: /home/username/.cache/pikaur/build/oomox-git/arc-theme is not a clone of https://github.com/actionless/arc-theme.git Aborting...

Do you want to proceed? [y/N]

I also tried to modify the PKGBUILD. But the result is the same:

-   "git+https://github.com/actionless/arc-theme.git#branch=resvg"
+   "git+https://github.com/actionless/arc-theme.git#branch=master"
[...]
    git config submodule.arc-theme.url $srcdir/arc-theme
+   git config submodule.arc-theme.branch resvg
    git config submodule.archdroid-icon-theme.url $srcdir/archdroid-icon-theme

friday13 commented on 2018-07-12 11:51

:: Proceed with installation? [Y/n] y (32/32) checking keys in keyring [##############################################] 100% (32/32) checking package integrity [##############################################] 100% error: libsass: signature from "Jerome Leclanche jerome@leclan.ch" is unknown trust :: File /var/cache/pacman/pkg/libsass-3.4.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] y error: sassc: signature from "Jerome Leclanche jerome@leclan.ch" is unknown trust :: File /var/cache/pacman/pkg/sassc-3.4.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] y error: failed to commit transaction (invalid or corrupted package) Errors occurred, no packages were upgraded. 2018-07-12 17:30:08,009 - wrappers - pacman - ERROR - pacman query ['sudo', 'pacman', '--sync', '--asdeps', '--', 'libsass', 'sassc', 'parallel', 'bc', 'gtk-engines', 'python-pillow', 'optipng', 'hunspell', 'hspell', 'libvoikko', 'aspell', 'enchant', 'gtkspell', 'libsigc++', 'glibmm', 'atkmm', 'cairomm', 'pangomm', 'gtkmm', 'gsl', 'libmagick6', 'potrace', 'poppler', 'poppler-glib', 'boost-libs', 'librevenge', 'libwpd', 'libcdr', 'inkscape', 'python-gobject', 'zip', 'gtk-engine-murrine'] failed

actionless commented on 2018-07-12 11:33

@friday13

you having a problem with libsass, not with oomox-git, so please report it accordingly (mb your keyring is too old so you just need to do a pacman -Syu)

friday13 commented on 2018-07-12 11:30

:: Proceed with installation? [Y/n] y (32/32) checking keys in keyring [##############################################] 100% (32/32) checking package integrity [##############################################] 100% error: libsass: signature from "Jerome Leclanche jerome@leclan.ch" is unknown trust :: File /var/cache/pacman/pkg/libsass-3.4.7-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] y error: sassc: signature from "Jerome Leclanche jerome@leclan.ch" is unknown trust :: File /var/cache/pacman/pkg/sassc-3.4.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] y error: failed to commit transaction (invalid or corrupted package) Errors occurred, no packages were upgraded. 2018-07-12 17:30:08,009 - wrappers - pacman - ERROR - pacman query ['sudo', 'pacman', '--sync', '--asdeps', '--', 'libsass', 'sassc', 'parallel', 'bc', 'gtk-engines', 'python-pillow', 'optipng', 'hunspell', 'hspell', 'libvoikko', 'aspell', 'enchant', 'gtkspell', 'libsigc++', 'glibmm', 'atkmm', 'cairomm', 'pangomm', 'gtkmm', 'gsl', 'libmagick6', 'potrace', 'poppler', 'poppler-glib', 'boost-libs', 'librevenge', 'libwpd', 'libcdr', 'inkscape', 'python-gobject', 'zip', 'gtk-engine-murrine'] failed