Package Details: opam-git 2.1.0.beta4.r13.g6929b39c-1

Git Clone URL: https://aur.archlinux.org/opam-git.git (read-only, click to copy)
Package Base: opam-git
Description: OCaml package manager
Upstream URL: https://opam.ocaml.org/
Licenses: GPL
Conflicts: opam
Provides: _opam-git
Submitter: zhehao
Maintainer: Rucikir
Last Packager: Rucikir
Votes: 7
Popularity: 0.000000
First Submitted: 2012-08-30 14:34 (UTC)
Last Updated: 2021-01-31 10:41 (UTC)

Dependencies (9)

Required by (0)

Sources (1)

Latest Comments

tchajed commented on 2017-05-14 21:17 (UTC)

Could you add a dependency on unzip? It's not in base but opam init fails without it.

vbmithr commented on 2014-05-07 08:39 (UTC)

Updated, thanks.

Drup commented on 2014-05-06 14:46 (UTC)

http://pastebin.archlinux.fr/506849 Here is the adapted pkgbuild for new build system upstream. Parallel build is broken, so I forced -j 1.

vbmithr commented on 2014-04-13 14:21 (UTC)

Updated.

Drup commented on 2014-04-01 17:00 (UTC)

The address of the repository changed, you should use this one : https://github.com/ocaml/opam

vbmithr commented on 2013-12-19 13:12 (UTC)

Ok, updating that.

acieroid commented on 2013-12-18 07:53 (UTC)

The PKGBUILD has wget in its makedepends array, but wget is not needed to build nor to use this package (curl is provided in archlinux's base (while wget is not) and is used to download stuff during the build).

dpro commented on 2013-10-24 04:46 (UTC)

Works now, after today's ocaml update, doesn't need the -compiler-libs package BTW. cheers

dpro commented on 2013-10-23 12:53 (UTC)

I tried with and without ocaml-compiler-libs, gives me the same error.

vbmithr commented on 2013-10-23 09:09 (UTC)

Do you have ocaml-compiler-libs installed ?

dpro commented on 2013-10-23 08:39 (UTC)

Hi, I am unable to build this (nor opam 1.0.0-1), I keep getting: . . make -C ocp-build make[1]: Entering directory '/tmp/yaourt-tmp-x/aur-opam-git/src/opam-git/ocp-build' awk '{ print "external "$1": unit -> unit = \"" $1 "\"" }' primitives > primitives.ml ocamlc -o ocp-build.run -custom -make-runtime win32_c.c primitives.ml unix.cma -cclib -lunix /usr/bin/ld: cannot find -lunix /usr/bin/ld: cannot find -lunix /usr/bin/ld: cannot find -lcamlrun collect2: error: ld returned 1 exit status File "primitives.ml", line 1: Error: Error while building custom runtime system Makefile:4: recipe for target 'ocp-build' failed make[1]: *** [ocp-build] Error 2 make[1]: Leaving directory '/tmp/yaourt-tmp-x/aur-opam-git/src/opam-git/ocp-build' Makefile:47: recipe for target 'ocp-build/ocp-build' failed make: *** [ocp-build/ocp-build] Error 2 this also happens when I try a clean git checkout and do a ./configure && make manually. Any hints much appreciated TIA

vbmithr commented on 2013-03-04 12:32 (UTC)

Fixed.

SebRmv commented on 2013-03-01 22:25 (UTC)

I think also that pkgver is bogus: please fix it! In yaourt, it appears as +%Y%m%d-1 (ie it is not substituted by the current value of day, month and year). Thus, every time I update my distro with "yaourt -Syua", opam-git appears as an updated package, which is quite annoying. I thus disinstalled opam. Cheers

vbmithr commented on 2013-02-26 17:44 (UTC)

No it is not bogus, it ensure that the package version is equal to the date minus one, which is the desired behaviour. Please explain why do you find that bogus. Cheers,

baskerville commented on 2013-02-26 16:38 (UTC)

The `pkgver` attribute is bogus.

vbmithr commented on 2012-09-20 08:07 (UTC)

Please update this package as well (use ./configure ...) Thanks!