Package Details: openbazaar-git v2.3.4.r2.g269bc33d-1

Git Clone URL: https://aur.archlinux.org/openbazaar-git.git (read-only)
Package Base: openbazaar-git
Description: Front-end Electron application for talking with the OpenBazaar daemon (Latest devel version)
Upstream URL: https://github.com/OpenBazaar/openbazaar-desktop
Licenses: MIT
Conflicts: openbazaar
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 10
Popularity: 0.000000
First Submitted: 2014-08-11 16:05
Last Updated: 2019-07-20 14:42

Dependencies (3)

Required by (0)

Sources (3)

Latest Comments

« First ‹ Previous 1 2

mueslo commented on 2014-11-19 16:15

Missing python2-psutil dependency.

atweiden commented on 2014-09-12 14:47

python2-argparse is part of the official python2 pkg, so it isn't needed. python2-bitcoin (1.1.13) is the actively maintained version of pybitcointools.

zpAUHlWLSNdNqVSU commented on 2014-08-26 21:55

Missing 'pybitcointools'

zpAUHlWLSNdNqVSU commented on 2014-08-24 15:42

Thanks for adding pysqlcipher, can confirm it works fully now.

zpAUHlWLSNdNqVSU commented on 2014-08-23 16:03

Missing pysqlcipher.

swiftgeek commented on 2014-08-17 22:01

2. chmod/chmod+chown for new group and optionally moving needed dir to var/srv (i'm not even sure how this thing should work)
3. nongit python2-obelisk fails to install anything
4. git python2-obelisk misses line about providing python2-obelisk

robertfoster commented on 2014-08-17 21:52

@swiftgeek
1)pyelliptic folder fixed2
2)if you use systemctl start openbazaar, no error; if you launch the standalone /usr/bin/openbazaar you have to type sudo before, cause in both conditions the openbazaar executable has to be launched with root privileges. Have an idea or a proposal to fix the "issue"? I've written a PKGBUILD creating and using the openbazaar user but i've had many problems

swiftgeek commented on 2014-08-17 21:36

Even after i install python2-tornado it fails to run from /opt
And fail to run if i copy it -.-
ImportError: No module named obelisk
(python2-obelisk is installed)

swiftgeek commented on 2014-08-17 21:31

/usr/bin/python2
mkdir: cannot create directory 'db': Permission denied
Production Mode
File ob.db does not exist. Running setup script.
DB_PATH db/ob.db
Traceback (most recent call last):
File "node/setup_db.py", line 168, in <module>
setup_db(DB_PATH)
File "node/setup_db.py", line 22, in setup_db
con = sqlite3.connect(db_path)
sqlite3.OperationalError: unable to open database file
Traceback (most recent call last):
File "node/tornadoloop.py", line 2, in <module>
import tornado.web
ImportError: No module named tornado.web

No idea wtf

swiftgeek commented on 2014-08-17 21:29

rm: cannot remove 'openbazaar/pyelliptic': No such file or directory