Package Details: opencbm 0.4.99.104-1

Git Clone URL: https://aur.archlinux.org/opencbm.git (read-only, click to copy)
Package Base: opencbm
Description: OpenCBM allows access to Commodore (C64) floppy drives 1540, 1541, 1570, 1571, 1581
Upstream URL: https://github.com/OpenCBM/OpenCBM
Keywords: 1540 1541 1570 1571 1581 4031 4040 8050 c64 cbm commodore
Licenses: GPL-2.0-only
Conflicts: opencbm
Provides: opencbm
Submitter: uffe
Maintainer: uffe
Last Packager: uffe
Votes: 3
Popularity: 0.000136
First Submitted: 2018-02-25 02:54 (UTC)
Last Updated: 2024-05-19 11:13 (UTC)

Dependencies (4)

Required by (1)

Sources (1)

Latest Comments

1 2 Next › Last »

BennehBoy commented on 2024-05-28 21:00 (UTC)

Resolved,

For anyone interested opencbm_plugin_helper_tools seems to be broken on Arch, so you need to copy /etc/opencbm.conf.sample to /etc/opencbm.conf and set your preferred default plugin within that copied config.

BennehBoy commented on 2024-05-28 20:13 (UTC)

just wish I could get it to work now, don't see a device appear and keep getting:

cbmctrl: NO PLUGIN DRIVER!: No such file or directory

udev rules seem OK and are loaded.

I can see the zoomfloppy using lsusb, and can communicate with it using: xum1541cfg devinfo finding device... xum1541 device, model 2 (ZOOMFLOPPY), firmware version 8

uffe commented on 2024-05-28 19:09 (UTC)

@BennehBoy no problem - good to hear that you got it working :-)

uffe commented on 2024-05-28 19:04 (UTC)

@BennehBoy Regarding build failure with cc65 - ok that explains...

BTW: I just did a rebuild the AUR package for cc65-2.19 and it compiled fine on my system...

BennehBoy commented on 2024-05-28 19:02 (UTC)

OK, all good now that I built using cc65-git.

Apologies.

BennehBoy commented on 2024-05-28 18:53 (UTC)

OK, my bad, it's actually cc65 that fails to build.

BennehBoy commented on 2024-05-28 18:40 (UTC) (edited on 2024-05-28 18:47 (UTC) by BennehBoy)

The git version also fails to build.

Output is too large for pastebin btw.

BennehBoy commented on 2024-05-28 18:39 (UTC)

It's too large for my console history :D

These seem to be the germane parts:

../libwrk/apple2enh/_scanf.s(266): Error: Local scope was not closed make[3]: *** [Makefile:283: ../libwrk/apple2enh/_scanf.o] Error 1 make[2]: *** [geos-apple/targetutil/Makefile.inc:9: ../lib/apple2enh.lib] Error 2 make[1]: *** [Makefile:118: geos-apple] Error 2 make[1]: *** Waiting for unfinished jobs.... make: *** [Makefile:7: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... error: failed to build 'cc65-2.19-1': error: can't build opencbm-0.4.99.104-1, deps not satisfied: cc65 error: packages failed to build: cc65-2.19-1 opencbm-0.4.99.104-1

uffe commented on 2024-05-28 18:27 (UTC) (edited on 2024-05-28 18:28 (UTC) by uffe)

@BennehBoy: a little more info would be helpful - any errors ?

if want you could provide the full compile output on a online copy/paste service as this system has a limit of 5000 chars...

BTW: I just tested and built opencbm - and it compiled fint - below is the output from the last stages of the build...

==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "opencbm"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: opencbm 0.4.99.104-1 (2024-05-28T20:19:34 CEST)
==> Cleaning up...

The problem as simple a missing dependency in PKGBUILD - one that I have installed on my system.

Are you able to build the "opencbm-git" AUR package ? it is more recent

BennehBoy commented on 2024-05-28 16:22 (UTC)

Unable to get this to build currently.