Package Details: openchange 2.3-7

Git Clone URL: (read-only)
Package Base: openchange
Description: A portable, open source implementation of Microsoft Exchange server and Exchange protocols.
Upstream URL:
Licenses: GPL3
Submitter: a1russell
Maintainer: DJ_L
Last Packager: Zrax
Votes: 28
Popularity: 0.000002
First Submitted: 2010-08-20 16:19
Last Updated: 2016-06-03 16:20

Latest Comments

DJ_L commented on 2017-12-29 21:18 If you need now, take a look at the patchset in that srpm.

DJ_L commented on 2017-12-29 20:47

I too no longer use this package. As of today's date, all currently supported versions of Microsoft Outlook in the regular support cycle (2013 and 2016) have support for EAS, so need for this package is limited at best. I suspect a few might still need libmapi for older Exchange servers, but those are really old and out of support as well. I'll take a look at maybe getting libmapi to build standalone in a week or so, but if anybody who still uses this package would like to step up, speak up and it's yours, else I'll probably just abandon it (short of libmapi standalone). Only currently continued development that I'm aware of is at

blha303 commented on 2017-12-29 08:11

openchange currently broken due to upstream breaking api change, opened issue here

Zrax commented on 2017-10-19 01:11

I don't use this package any more. Feel free to adopt it and add your fixes.

corossig commented on 2017-10-18 13:14

Patch for fixing compilation :

DJ_L commented on 2016-07-11 23:08

I'm sorry I've never followed up on my previous comment. The Zentyal folks have continued development of OpenChange and are doing their releases (tagged) from here: which "should" work out of the box with 4.4 (though I have not tested it myself).

DJ_L commented on 2016-06-07 01:57

Hey, just FYI, while nothing is happening at official upstream, the inverse team is working on bringing it up to Samba-4.2. Should see something this week.

student975 commented on 2016-06-06 10:35

Is working now, thanks!

Zrax commented on 2016-06-03 16:22

It looks like they renamed their pkgconfig file in 0.9... :( I've added a patch to make it work again.

student975 commented on 2016-06-03 15:40

Hi! Have got:

checking whether gcc understands -c and -o together... (cached) yes
checking dependency style of gcc... (cached) none
checking for CHECK... yes
checking for NANOMSG... no
configure: error: Install nanomsg library >= 0.5
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build openchange.
==> Restart building openchange ? [y/N]
==> -----------------------------------


~ $ pacman -Qs nanomsg
local/nanomsg 0.9-1
Simple high-performance implementation of several "scalability protocols"

How to resolve?

All comments