Package Details: opencl-amd 19.30.838629-1

Git Clone URL: https://aur.archlinux.org/opencl-amd.git (read-only)
Package Base: opencl-amd
Description: OpenCL userspace driver as provided in the amdgpu-pro driver stack. This package is intended to work along with the free amdgpu stack.
Upstream URL: http://www.amd.com
Keywords: amd amdgpu computing gpgpu opencl radeon
Licenses: custom:AMD
Conflicts: amdgpocl
Provides: opencl-driver
Submitter: grmat
Maintainer: grmat
Last Packager: grmat
Votes: 66
Popularity: 2.130456
First Submitted: 2016-12-01 03:45
Last Updated: 2019-07-09 15:12

Required by (21)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Olympus593 commented on 2018-12-25 14:40

@grmat same copy to host problem on SI and CI cards. The only known workaround is by appending a null kernel but it can only work for individual programs

grmat commented on 2018-12-22 15:14

I've updated to 18.50, but I don't own a CI card anymore, so please let me know if there are problems with older hardware (even better if you already know workarounds that could be included).

BTW, if you feel like the package updates are too slow and want to jump in as co-maintainer, just contact me.

agapito commented on 2018-12-22 12:27

Libdrm workaround is not needed anymore. I am using blender-git package and opencl-amd 18.50. I can render using CPU + GPU.

Nightbane112 commented on 2018-12-21 06:33

@Ashark Have you still using the libdrm workaround with this package? I upgraded this package using your PKGBUILD but both SVP4 and Blender was crashing after the upgrade. So, I tried to launch without the libdrm workaround (LD_PRELOAD=/usr/lib/libdrm_amdgpo.so.1.0.0) and both apps started to work. You might want to try this if was working before.

Olympus593 commented on 2018-12-21 04:19

@Ashark AMD had not yet confirmed if OpenCL is fixed on SI cards. They used to have a list of supported APIs on their release notes but since 18.40, it does not show up anymore

Olympus593 commented on 2018-12-12 06:26

It is confirmed. SI and CIK cards are having copy to host issues. This is most likely a problem with AMD as only OpenCL is suffering from problems when using experimental SI and CIK support.

Update: AMD's OpenCL implementation is crippled on GCN 1 cards as of v18.40. Guess GCN 1 owners will have to wait for AMD to fix the issue or revert back to Catalyst.

rigred commented on 2018-12-10 11:16

Here's my patch to get yourself version 18.40

https://gist.githubusercontent.com/rigred/d5df1647d4c718dd28c1a9035cadbdd7/raw/25c443d1c1e60fe61efe808c2e5ff83e2cbf7f35/opencl-amd-18.40.patch

Let me know if anyone finds any issues upgrading

To solve the blender/libdrm related issues you can use:

LD_PRELOAD=/usr/lib/libdrm_amdgpo.so.1.0.0

agapito commented on 2018-11-26 13:38

I found a better solution here: https://bugs.archlinux.org/task/60061

Upgrade your system, compile libdrm and just save libdrm_amdgpu.so.1.0.0 library and preload it to Blender. It works fine here.

mowcat commented on 2018-11-22 12:30

Does anyone know if the blender issue

amdgpu_device_initialize: amdgpu_query_info(ACCEL_WORKING) failed (-9)

when using openCL and cycles, currently I'm running a downgraded libdrm (version 2.4.93-1) to solve this; or workaround.

If this needs more work or investigation I'll happily help debug this, I think the problem is in AMD's upstream driver that opencl_amd uses. Please correct me if I'm wrong...

Olympus593 commented on 2018-11-14 13:13

@linnaea only AMD can fix the issue but most likely they will never fully develop SI and CIK support.