Package Details: opencl-amd 19.20.812932-1

Git Clone URL: https://aur.archlinux.org/opencl-amd.git (read-only)
Package Base: opencl-amd
Description: OpenCL userspace driver as provided in the amdgpu-pro driver stack. This package is intended to work along with the free amdgpu stack.
Upstream URL: http://www.amd.com
Keywords: amd amdgpu computing gpgpu opencl radeon
Licenses: custom:AMD
Conflicts: amdgpocl
Provides: opencl-driver
Submitter: grmat
Maintainer: grmat
Last Packager: grmat
Votes: 66
Popularity: 2.052991
First Submitted: 2016-12-01 03:45
Last Updated: 2019-07-19 18:25

Required by (21)

Sources (1)

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 Next › Last »

grmat commented on 2017-12-24 13:03

just got time to look at the issue. In fact, some paths have changed (thanks @Noctivivans). I didn't experience regressions yet, so I pushed the update out. Sorry for the delay

Noctivivans commented on 2017-12-23 01:47

@utsi: have you checked reason of segfault? I noticed that paths in 17.50 are little different which caused segfault of e.g. clinfo.

Here is my quick-ugly-fixed PKGBUILD (in my version amdgpu.ids is in /opt/amdgpu instead of /opt/amdgpu-pro, I am not sure if that's correct way to do it but at least it works; tested on xmr-stak and clinfo):

https://pastebin.com/QvdgvFqm

works with 4.14.8-1-ARCH kernel and amdgpu driver (without binary blob), I have no other opencl packages installed.

Atraii commented on 2017-12-20 17:18

I'm confused on how to get the icd to load this. clinfo reports only OpenCL 1.1 Mesa 17.3.0 on Clover. I don't have the newer OpenCL 1.2. Is there a dependency I'm missing?

Edit: Looks like I'm not the only one https://bbs.archlinux.org/viewtopic.php?id=232446

utsi commented on 2017-12-18 22:22

I tried modifying the package to get 17.50 to work but sadly OpenCL apps segfault when you start them, so it is not just you :\

grmat commented on 2017-12-16 14:19

I know 17.50 has been released this week, but it currently seems broken with my setup.

I have no data for other setups. If some testers could tell me everything's fine with their newer hardware or an amd kernel, I'd push out 17.50 to the aur.

grmat commented on 2017-11-03 00:54

This package is providing the older opencl runtime, running on the graphics stack with amdgpu and libdrm. If you want to runn the ROCm stack, you should look into that or the packages that leidola provides in the AUR.

cmdline parameters clearly have nothing to do with this package, as we're not touching kernel modules at all. The amdgpu.vm_fragment_size parameter will be introduced in kernel 4.14. If you need this, you'll have to build the current RC, something out of AMD's branches or use the -pro module.

1llum1n4t3d commented on 2017-11-03 00:12

Also need to put "amdgpu.vm_fragment_size=9" in 'GRUB_CMDLINE_LINUX_DEFAULT' or 'GRUB_CMDLINE_LINUX' for Arch Linux? Please respond.

grmat commented on 2017-11-03 00:01

Thanks for the notification, updated to 17.40

1llum1n4t3d commented on 2017-11-02 23:34

Please update! 17.40 is out! Also it have the blockchain compute fix! Read: https://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Driver-for-Linux-Release-Notes.aspx

Enabling Large Page Support
The syntax of this module parameter is amdgpu.vm_fragment_size=X, where the actual fragment size is 4KB * 2^X. The default is X=4, which means 64KB. To get 2MB fragments, set X=9.

Edit /etc/default/grub as root and modify GRUB_CMDLINE_LINUX_DEFAULT in order to add "amdgpu.vm_fragment_size=9" (without the quotes). The line may look something like this after the change:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash amdgpu.vm_fragment_size=9"
Update grub and reboot as root:
update-grub;reboot

laichiaheng commented on 2017-10-31 18:15

==> Validating source files with sha256sums...
amdgpu-pro-17.30-465504.tar.xz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build opencl-amd.