Package Details: opencl-catalyst 15.9-8

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Package Base: catalyst-utils
Description: AMD/ATI drivers. OpenCL implemention for AMD Catalyst
Upstream URL: http://www.amd.com
Licenses: custom
Conflicts: opencl-amd
Provides: opencl-driver
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 61
Popularity: 0.088436
First Submitted: 2013-04-29 09:04
Last Updated: 2017-04-03 19:21

Dependencies (3)

Required by (16)

Sources (12)

Pinned Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Latest Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

lmat commented on 2017-03-14 14:57

I'm getting the following conflict attempting to install catalyst-utils:

==> Finished making: catalyst-utils 15.9-7 (Tue Mar 14 10:50:42 EDT 2017)
==> Installing catalyst-utils package group with pacman -U...
[sudo] password for lawsa:
loading packages...
resolving dependencies...
warning: cannot resolve "xorg-server<1.18.0", a dependency of "catalyst-utils"
warning: cannot resolve "xorg-server<1.18.0", a dependency of "catalyst-utils"
warning: cannot resolve "catalyst-utils", a dependency of "catalyst-libgl"
:: The following packages cannot be upgraded due to unresolvable dependencies:
catalyst-utils catalyst-libgl

:: Do you want to skip the above packages for this upgrade? [y/N]



(Looks like my xorg-server is 1.19.) Any suggestions?

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Vi0L0 commented on 2015-10-18 09:37

GNOME 3.18 fix
In [catalyst] and [catalyst-stable] you may find a new package cogl 1.22.0-2. It brings fix for recent problems with new GNOME 3.18 and new GDM (it baheves strange with plasma though, after choosing plasma and entering password I have to switch to tty and then back to X to see plasma desktop, probably another bug).
Source and a patch is here: http://mirror.rts-informatique.fr/archlinux-catalyst/tarball/gnome318-problems/cogl-1.22.0-2.src.tar.gz

Vi0L0 commented on 2015-10-07 20:41

@er***: many users are experiencing freezes here:
https://bbs.archlinux.org/viewtopic.php?pid=1568368#p1568368
I'm gonna paste your story there, maybe it will help someone.
Hope you don't mind, whoever you are ;) (as I can see that your account doesn't exist anymore)

Vi0L0 commented on 2015-09-29 20:29

be aware that I removed linux from dependency array and so it will let linux to update (while it's not supported tongue), if you will not configure bootloader to use kernel older than 4.2, like linux-lts, it will probably boot linux and you will probably gonna see a freeze or blank screen. System should work though, you can ssh to it and config bootloader from here, or use single mode if you can't ssh, or well there's possibility that linux-lts was added before, boot it and config as default kernel to boot.

Vi0L0 commented on 2015-09-29 20:28

updated to 15.9
4.2 kernel is in [core] and we still don't have support for it.
So for now please use linux-lts kernel.

Vi0L0 commented on 2015-07-09 18:59

couple of words about 15.7::
OpenGL is now in 4.5 version, it brings fixes for some titles like borderlands 2 which now works well, still looks like crap smile but at least its fluid. Even warsow seems snappier, but it's not mindblowing. Dota 2 is kinda laggy in some situations, plus it crashed on exit (sic!) and I wasn't able to kill its process (sadface, at least it wasnt eating resources, only ate some ram and sit)...
They fixed vaapi which latelly wasn't working with -va vaapi option.
It does support xserver 1.17, but tty - just like with ubuntu 15.4 version - is all black - another sadpanda.
And ofcourse glitching (on plasma DE) chromium - cherry on the top.


I don't think it deserves [catalyst-stable] or catalyst@AUR...

I will put it into [catalyst] for now, catalyst-test@AUR already is updated

Vi0L0 commented on 2015-06-04 13:22

updated to 15.5-1 - AKA "nothing interesting":
- it doesn't support xserver 1.17
- looks older than ubuntu vivid driver which we are using ie in catalyst-test@AUR
- rel notes: http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst15-5LINReleaseNotes.aspx

All comments