Package Details: opencl-mesa-noglvnd 18.0.2-1

Git Clone URL: https://aur.archlinux.org/mesa-noglvnd.git (read-only)
Package Base: mesa-noglvnd
Description: OpenCL support for AMD/ATI Radeon mesa drivers - non-libglvnd version
Upstream URL: https://www.mesa3d.org/
Licenses: custom
Conflicts: opencl-mesa, opencl-mesa-git
Provides: opencl-driver, opencl-mesa
Replaces: opencl-mesa, opencl-mesa-git
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 3
Popularity: 0.015033
First Submitted: 2017-04-02 20:33
Last Updated: 2018-04-29 16:05

Required by (20)

Sources (6)

Latest Comments

npfeiler commented on 2018-05-19 13:53

PKGBUILD patch for mesa-18.0.4 (extra/wayland 1.15.0 combat) https://pastebin.com/tSiUmaW3

Vi0L0 commented on 2018-04-29 16:07

maybe update will help. I don't have problems with it but in case of any - let me know. Soon it will be also available in catalyst repositories

Tralen commented on 2018-04-24 01:35

I got the same error as @VojtechHauser.

Edit: I was able to compile by downgrading clang, llvm and llvm-libs to 4.0.1-3. I think version 5 would work as well, but I used what I had cached.

Edit: It doesn't work, mesa can't find the llvm libs required.

VojtechHauser commented on 2018-04-15 22:09

The build fails for me (Linux <hostname> 4.15.15-1-ARCH #1 SMP PREEMPT Sat Mar 31 23:59:25 UTC 2018 x86_64 GNU/Linux, GCC 7.3.1 20180312) with the following message:</hostname>

   CXX      gallivm/lp_bld_misc.lo

   gallivm/lp_bld_misc.cpp: In function ‘LLVMOpaqueBuilder* 
   lp_create_builder(LLVMContextRef, lp_float_mode)’:

   gallivm/lp_bld_misc.cpp:787:13: error: ‘class llvm::FastMathFlags’ has no member named ‘setUnsafeAlgebra’

   flags.setUnsafeAlgebra();

         ^~~~~~~~~~~~~~~~

nileshmoodley commented on 2017-07-03 16:53

I am having the same file conflicts as @kusayu.

@Vi0L0 all the files are are owned by libglvnd

Vi0L0 commented on 2017-06-23 18:25

@kusayu and the owner of this file is?...
pacman -Qo /usr/lib/libEGL.so
please tell so I could eventually modify the package

kusayu commented on 2017-06-23 16:13

ok, for some reason, on a clean fresh OS it builds, but cannot be installed due to

error: failed to commit transaction (conflicting files)
mesa-noglvnd: /usr/lib/libEGL.so exists in filesystem
mesa-noglvnd: /usr/lib/libEGL.so.1 exists in filesystem
mesa-noglvnd: /usr/lib/libEGL.so.1.0.0 exists in filesystem
mesa-noglvnd: /usr/lib/libGL.so exists in filesystem
mesa-noglvnd: /usr/lib/libGL.so.1 exists in filesystem
mesa-noglvnd: /usr/lib/libGLESv1_CM.so exists in filesystem
mesa-noglvnd: /usr/lib/libGLESv1_CM.so.1 exists in filesystem
mesa-noglvnd: /usr/lib/libGLESv2.so exists in filesystem

kusayu commented on 2017-06-22 08:27

I have a problem making it. How can i fix it?

CXXLD vulkan/libvulkan_intel.la
vulkan/.libs/libvulkan_common.a(vulkan_libvulkan_common_la-anv_device.o): In function `anv_EnumeratePhysicalDevices':
anv_device.c:(.text+0x45a): undefined reference to `drmGetDevices2'
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:2425: vulkan/libvulkan_intel.la] Error 1
make[4]: Leaving directory '/home/kusayu/.cache/pacaur/mesa-noglvnd/src/mesa-17.1.0/src/intel'
make[3]: *** [Makefile:1972: all] Error 2
make[3]: Leaving directory '/home/kusayu/.cache/pacaur/mesa-noglvnd/src/mesa-17.1.0/src/intel'
make[2]: *** [Makefile:851: all-recursive] Error 1
make[2]: Leaving directory '/home/kusayu/.cache/pacaur/mesa-noglvnd/src/mesa-17.1.0/src'
make[1]: *** [Makefile:642: all] Error 2
make[1]: Leaving directory '/home/kusayu/.cache/pacaur/mesa-noglvnd/src/mesa-17.1.0/src'
make: *** [Makefile:642: all-recursive] Error 1
==> ERROR: A failure occurred in build().

malbeth commented on 2017-05-18 22:25

To install this package until the maintainer updates it, simply download the latest snapshot and edit the PKGBUILD file, change the line
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D')
to
validpgpkeys=('946D09B5E4C9845E63075FF1D961C596A7203456')
and execute makepkg.

Ternvein commented on 2017-05-18 19:26

I can confirm that makepkg complains about PGP signature of mesa-17.0.5.tar.xz.

==> Verifying source file signatures with gpg...
mesa-17.0.5.tar.xz ... FAILED (invalid public key 946D09B5E4C9845E63075FF1D961C596A7203456)
==> ERROR: One or more PGP signatures could not be verified!

All comments