Package Details: opencv-samples-git 4.6.0.r213.gbb64db98d8-1

Git Clone URL: https://aur.archlinux.org/opencv-git.git (read-only, click to copy)
Package Base: opencv-git
Description: Open Source Computer Vision Library (samples)
Upstream URL: https://opencv.org/
Licenses: BSD
Conflicts: opencv, opencv-samples, python-opencv
Submitter: chenxing
Maintainer: andrewSC
Last Packager: andrewSC
Votes: 43
Popularity: 0.006264
First Submitted: 2012-07-31 00:21 (UTC)
Last Updated: 2022-08-27 19:50 (UTC)

Dependencies (25)

Required by (3)

Sources (3)

Latest Comments

1 2 3 4 5 6 .. 13 Next › Last »

Melechtna commented on 2024-01-07 11:23 (UTC) (edited on 2024-01-07 12:52 (UTC) by Melechtna)

evorster, could you define "latest versions of java and the jdk"? I have 21.u35-8 for the openJDK, but it won't let me simultaneously install that for the JRE, so, I have no idea what you mean.

Edit: Figured it out, for anyone else with this issue, archlinux-java status, see which is the latest, then archlinux-java set (latest), so for example, mine was java-21-openjdk, so, archlinux-java set java-21-openjdk (needs to be run as root), and it built just fine.

evorster commented on 2023-05-28 07:45 (UTC)

To solve the dependency issues, each package needs to provide and conflict with it's own non-git version.

evorster commented on 2023-05-28 07:23 (UTC)

I got that error below sorted by installing the latest versions of java, and the jdk. The problem I am running into now is that a few of my installed packages depend on "opencv" and this package conflicts with opencv, but does not provide it.

Can we add: provides=('opencv') somewhere in the PKBUILD, please?

evorster commented on 2023-05-27 23:39 (UTC)

Hi there! This package almost builds, I get this error in the install phase:

-- Installing: /mnt/int/system/aur/opencv-git/pkg/opencv-git/usr/share/opencv4/samples/python/watershed.py
ln: failed to create symbolic link '/mnt/int/system/aur/opencv-git/pkg/opencv-git/usr/share/java/opencv.jar': No such file or directory
==> ERROR: A failure occurred in package_opencv-git().
    Aborting...

fiatguy85 commented on 2023-04-16 19:14 (UTC) (edited on 2023-04-17 02:02 (UTC) by fiatguy85)

I was having issues compiling and getting the following error:

/usr/include/absl/base/policy_checks.h:79:2: error: #error "C++ versions less than C++14 are not supported."
   79 | #error "C++ versions less than C++14 are not supported."
      |  ^~~~~

This appears to be related to this bug in opencv.

Adding the following to the _cmakeopts got it to compile:

-DCMAKE_CXX_STANDARD=17

d4l3k commented on 2022-07-20 04:30 (UTC)

Seems like opencv-python doesn't support ffmpeg 5.0 so can't compile on latest Arch

In file included from /home/rice/.cache/yay/opencv-git/src/opencv/modules/videoio/src/cap_ffmpeg.cpp:50:
/home/rice/.cache/yay/opencv-git/src/opencv/modules/videoio/src/cap_ffmpeg_impl.hpp: In member function ‘bool CvCapture_FFMPEG::open(const char*, const cv::VideoCaptureParameters&)’:
/home/rice/.cache/yay/opencv-git/src/opencv/modules/videoio/src/cap_ffmpeg_impl.hpp:1146:35: error: ‘AVStream’ {aka ‘struct AVStream’} has no member named ‘codec’
 1146 |         context = ic->streams[i]->codec;
      |                                   ^~~~~

andrewSC commented on 2022-04-08 22:17 (UTC)

Thanks for the heads up m00nw4tch3r (and others) and also thanks for the patience!(!!) I've refactored the package quite a bit and decided to split it as well. Let me know if this causes any issues.

As always, I was able to build this package in a clean chroot before pushing the changes so if you're experiencing build issues please attempt that first before reporting. Thanks!

=^.^=

m00nw4tch3r commented on 2022-04-08 15:30 (UTC)

Looks like the lapack patch isn't needed anymore, and it causes the build to fail.

sunnysun commented on 2022-03-02 05:50 (UTC) (edited on 2022-03-02 05:54 (UTC) by sunnysun)

It seems the patch is not working

==> Starting prepare()...
patching file modules/core/src/hal_internal.cpp
Hunk #1 FAILED at 163.
Hunk #2 FAILED at 174.
Hunk #3 FAILED at 185.
Hunk #4 FAILED at 227.
Hunk #5 FAILED at 288.
Hunk #6 FAILED at 309.
6 out of 6 hunks FAILED -- saving rejects to file modules/core/src/hal_internal.cpp.rej
==> ERROR: A failure occurred in prepare().
Aborting...
-> error making: opencv-git

carlosnewmusic commented on 2021-09-14 20:15 (UTC)

error build https://pastebin.com/CMUu3JQr