Package Details: opencv3-opt 3.4.16-1

Git Clone URL: https://aur.archlinux.org/opencv3-opt.git (read-only, click to copy)
Package Base: opencv3-opt
Description: Open Source Computer Vision Library (Legacy Version & /opt directory version)
Upstream URL: http://opencv.org/
Licenses: BSD
Provides: opencv3
Submitter: MichaelChou
Maintainer: foxxy
Last Packager: foxxy
Votes: 6
Popularity: 0.164639
First Submitted: 2019-02-13 12:43 (UTC)
Last Updated: 2022-06-27 09:58 (UTC)

Sources (5)

Latest Comments

1 2 3 4 Next › Last »

foxxy commented on 2022-06-27 09:59 (UTC)

Updated to 3.4.16. Had to disable -Werror=address and build again ffmpeg 4.4

foxxy commented on 2022-05-18 11:53 (UTC)

New upstream doesn't build for me, so can't update the package. Fixes/Suggestions welcome.

foxxy commented on 2022-02-14 12:30 (UTC)

Thanks @DrAtomic I've applied your patch to the package.

DrAtomic commented on 2022-02-11 05:46 (UTC)

applying @wbthomason

diff --git a/PKGBUILD b/PKGBUILD
index b0569ee..4df581e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,14 +22,17 @@ source=(
 "opencv-$pkgver.tar.gz::https://github.com/opencv/opencv/archive/$pkgver.zip"
 "opencv_contrib-$pkgver.tar.gz::https://github.com/opencv/opencv_contrib/archive/$pkgver.tar.gz"
 "opencv-lapack.patch::https://raw.githubusercontent.com/archlinux/svntogit-packages/ea851b9f93224a4c19cc3ddeafa7b733f3f138b6/opencv/repos/extra-x86_64/opencv-lapack-3.10.patch"
+"opencv-tbb.patch::https://raw.githubusercontent.com/DrAtomic/opencv-tbb-patch/main/opencv-tbb.patch"
 )
 sha256sums=('302d3fe23b09d608d14b10212ed25649d9b6c7a2f817ccb1c8005172a479dedb'
             'f8394bc68b70c57e54fc7706a4d2b7ef33e514c385f338c4cb470fe37d0dc243'
             'SKIP'
+            'SKIP'
 )

 prepare() {
   patch -d opencv-$pkgver -p1 < opencv-lapack.patch # Fix build with LAPACK
+  patch -d opencv-$pkgver -p1 < opencv-tbb.patch    # Fix build tbb
   mkdir -p build
 }

wbthomason commented on 2022-02-10 22:13 (UTC)

The actual patch needed is replacing line 104 in modules/core/src/parallel.cpp with #include "tbb/version.h".

theodore commented on 2022-02-03 14:19 (UTC)

Please update with the patch mentioned here https://github.com/SteveMacenski/slam_toolbox/issues/469#issuecomment-1019340480 since the package fails to compile due to the TBB changes.

bionade24 commented on 2021-07-04 08:23 (UTC)

Please stop marking this package out of date if there's an issue with this PKGBUILD. This is not what OOD requests are for, so I'll always just remove the OOD marking before doing anything.

I value the comments here as much, they're not enforcing it less.

fmauch commented on 2021-04-11 06:22 (UTC)

@MichaelChou I've updated the package on a fork: https://github.com/fmauch/aur_opencv3-opt

If you could fix this asap, this would be great, as this is currently failing inside our CI/CD pipeline.

fmauch commented on 2021-04-07 15:04 (UTC)

This currently doesn't build due to changed API in lapack.

extra/opencv provides a patch file for this: https://github.com/archlinux/svntogit-packages/blob/packages/opencv/trunk/opencv-lapack-3.9.1.patch

Using this works for me.