Package Details: opendune 0.9-4

Git Clone URL: https://aur.archlinux.org/opendune.git (read-only, click to copy)
Package Base: opendune
Description: Open source re-creation of the popular game Dune II
Upstream URL: http://opendune.org
Keywords: dune game rts strategy
Licenses: GPL2
Conflicts: opendune-git
Submitter: gaelic
Maintainer: None
Last Packager: Mr.Smith1974
Votes: 5
Popularity: 0.001030
First Submitted: 2017-02-20 09:24 (UTC)
Last Updated: 2023-11-14 06:11 (UTC)

Latest Comments

czardien commented on 2024-03-21 12:08 (UTC) (edited on 2024-03-21 13:32 (UTC) by czardien)

The Desktop application doesn't work; it does nothing for me. Trying to start from the CLI I got a bunch of unexpected issues:

$ opendune
opendune.ini file not found.
Cannot initialise files. Does ./data/ directory exist ?

I have to create the ~/.config/opendune/opendune.ini folder and the ~/.config/opendune/data/ folder and change directory to the ~/.config/opendune/ to get rid of those errors.

Then, I get:

No valid MIDI output ports.
  Please install and start Timidity++ like: timidity -iA
--------------------------
ERROR LOADING DATA FILE

Did you copy the Dune2 1.07eu data files into the data directory ?

So I install timidity++ and run it; which fixes the first part of that message. I am still a little stuck on that last bit. I have skimmed the docs on the project's page and have been looking for "data" files without luck so far.

Glorious7060 commented on 2023-11-14 05:54 (UTC)

Missing gendesk dependency, once I installed it I can build the game

OJaksch commented on 2023-07-20 05:07 (UTC)

The file opendune.desktop is missing, also it's reference in PKGBUILD.

irb commented on 2023-07-15 19:14 (UTC)

@MrSmith1974 Presumably the package that provides "SetFile".

Mr.Smith1974 commented on 2023-07-15 04:24 (UTC)

@irb

And what dependency is missing?

irb commented on 2023-07-14 20:34 (UTC) (edited on 2023-07-14 20:36 (UTC) by irb)

Probably a missing dependency?

==> Starting package()...
which: no SetFile in (PATH...)
make[1]: Entering directory '/usr/local/src/aur/opendune/src/OpenDUNE-0.9/objs/release'
make[1]: Nothing to be done for 'all'.
make[1]: Leaving directory '/usr/local/src/aur/opendune/src/OpenDUNE-0.9/objs/release'
[BUNDLE] Constructing bundle
[INSTALL] Installing OpenDUNE
install: cannot stat '../../opendune.desktop': No such file or directory

pbnoxious commented on 2020-01-08 10:17 (UTC)

I think the directory of the data files needs to be changed, I had to adjust it to /usr/share/games/dune2 Also I think (not really an expert) that deleting the data files from the dune2-data package is not really a good practice, as you'll strip the other package of its files. Probably that should be a build dependency?

zorun commented on 2018-02-08 07:34 (UTC)

Hi,

It builds fine with SDL in a clean chroot. But you're right, the build system seems to prefer SDL2 if present.

I have moved the package to use SDL2. I think I had settled for SDL because there was an issue with SDL2 (missing sound at runtime?). Please test and report.

blapierre commented on 2018-02-08 03:28 (UTC)

Doesn't build... i have all dependencies installed. fatal error: SDL_image.h: No such file or directory

But i have sdl & sdl2, so I was able to fix by also installing sdl2_image. So it seems if you have sdl2, you must also have sdl2_image installed.

Also, the code seems to indicate it wants SDL2, not SDL. If that's correct, please adjust the dependencies to sdl2 & sdl2_image.

zorun commented on 2017-08-13 15:22 (UTC)

Updated with several changes: - install in /usr/bin instead of /opt - correctly find data files - add missing dependencies - minor fixes