Package Details: openerp 7.0-13

Git Clone URL: https://aur.archlinux.org/openerp.git (read-only)
Package Base: openerp
Description: Advanced OpenSource ERP and CRM server
Upstream URL: http://openerp.com/
Licenses: GPLv3
Replaces: openerp-server, openerp-web
Submitter: bidossessi
Maintainer: bidossessi
Last Packager: bidossessi
Votes: 36
Popularity: 0.028694
First Submitted: 2012-03-12 08:41
Last Updated: 2016-08-27 08:24

Latest Comments

bidossessi commented on 2015-11-09 22:25

@ArthurBorsboom: Please report this to python2-unittest2's maintainer.

ArthurBorsboom commented on 2015-10-06 11:31

warning: cannot resolve "python2-traceback2", a dependency of "python2-unittest2"
:: The following package cannot be upgraded due to unresolvable dependencies:
python2-unittest2

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: python2-unittest2: requires python2-traceback2

bidossessi commented on 2015-01-28 17:20

A few things have changed in the openerp tarball. I updated the PKGBUILD accordingly.
For those of us who are still stuck on v7, enjoy!

bidossessi commented on 2014-10-14 12:41

this package is openerp v7, not odoo.
I will make a nightly odoo package as soon as I'm done trying it out thoroughly.
For now, I use OpenERP professionnally and need v7 for the community modules.
For those who need v8, I've seen some packages in the AUR. Please check them out, or make your own, or wait until I'm ready :-)

bidossessi commented on 2014-10-14 12:17

this package is openerp v7, not odoo.

perempty commented on 2014-10-04 23:16

@bidossessi : you can find the odoo packages at http://nightly.odoo.com

munzirtaha commented on 2014-09-21 15:02

Odoo 8.0 is now stable and released since September 18, 2014

ludat commented on 2014-09-12 20:17

Today I tried to compile it but it didn't work...
The version 7.0-20140422-231307 has been taken down for some reason.
So right now the downloader fails (file not found) and if you change the pkgver to a real one (like openerp-7.0-20140804-231303) the checksum fails.
Maybe the best would be just download the repo from github.

ludat commented on 2014-09-12 20:14

Today I tried to compile it but it didn't work...
The version 7.0-20140422-231307 has been taken down for some reason.
So right now the downloader fails (file not found) and if you change it the checksum also fails.

blaggacao commented on 2014-05-18 21:02

@bidossessi: Would it be difficult to adapte uour script to compile from source from the SaaS-branches on github?

This would be a great help. Thanks!

bidossessi commented on 2014-05-18 00:55

1. There is no Odoo package anywhere yet. Last Odoo release on github is from Jan 2013.
2. My package follows the 7.0 openerp that is _still_ being updated. See http://nightly.openerp.com for details.
3. Nightly's latest source _still_ installs as "openerp" in /usr/lib/python2.7/site-packages.
Until the three above change, this package will still be called openerp.
In the meantime, unless there's an issue with _this_ AUR build that requires me to update it in a hurry (before I'm ready), check your facts and stop flagging inconsiderately. Thanks.

mbrown commented on 2014-05-16 15:17

OpenERP has changed it's project name to Odoo.

See https://www.odoo.com/page/FAQ for details.

Source code is now hosted on Github (no more bazaar):

https://github.com/odoo/odoo

mbrown commented on 2014-05-16 15:17

OpenERP has changed it's project name to Odoo.

See https://www.odoo.com/page/FAQ for details.

Source code is now hosted on Github --- no more bazaar.

bidossessi commented on 2014-04-29 09:34

Hey folks.
I had the source but didn't have access to Internet.
Fixed pydot dependency.
Can't wait for OpenERP 8 to go stable. In the meantime, Enjoy!

felixonmars commented on 2014-03-25 03:17

Please update dependency pydot => python2-pydot, the latter is currently available in [community], thanks!

jorgejch commented on 2014-03-17 00:38

Had an issue from bug https://bugs.launchpad.net/openobject-addons/+bug/1281762. Updated the PKGBUILd to the version below, where issue was fixed.

http://nightly.openerp.com/7.0/nightly/src/openerp-7.0-20140316-003130.tar.gz

bidossessi commented on 2014-02-20 10:07

New update.
Included new dependencies on python2-jinja and python2-egenix-mx-base.
Enjoy

ChrisDennis commented on 2014-01-15 20:41

An update to my previous comment from last October...

I finally got round to using bidossessi's suggestions regarding upgrading postgresql to version 9.3 without breaking openerp (see his comment below from 2013-10-31). It all worked, except that I found that I didn't need to recreate the openerp user in postgres, but I did need to reinstall openerp -- for some reason that was enough to get things back into line, and I was able to restore my openerp database from the web interface.

Thanks again to bidossessi.

dun32 commented on 2014-01-03 07:52

Because I use timesheets, I needed mx-datetime.
Please, can you add python2-egenix-mx-base as a dependency ?

munzirtaha commented on 2013-12-29 15:59

I tried to "Send reset password link by email" and got this error:
AssertionError: email_from is missing or empty after template rendering, send_mail() cannot proceed

I managed to fix it by installing python2-jinja, Can you please add it as a dependency?

bidossessi commented on 2013-12-02 10:55

@munziraha: That is an issue for the zsi maintainer.

munzirtaha commented on 2013-11-30 07:09

openerp depends on zsi which depends on pyxml which is removed.

bidossessi commented on 2013-11-19 12:45

Updated to 2013/11/13 release.
Enjoy

dun32 commented on 2013-11-16 07:18

Thanks @bidossessi, update to python2-babel 1.3-2 solved it.

bidossessi commented on 2013-11-13 09:27

@dun32
I'm assuming you work in a multi-lingual environment and were hit by this bug:
https://bugs.archlinux.org/task/37435

It should have been fixed by python2-babel 1.3-2, but I'm yet to test it myself.

dun32 commented on 2013-11-12 07:14

After pacman -Syu on my server, I had to downgrade python2-babel from 1.3-1 to 0.9.6-4.

The error I was getting was :

nov. 12 07:55:39 ArchServer openerp-server[432]: OpenERP Server 7.0-20130811-231021:?:ERROR:openerp.addons.web.http.JSONRequest.dispatch:An error occured while handling a json request
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/openerp/addons/web/http.py", line 204, in dispatch
response["result"] = method(self, **self.params)
File "/usr/lib/python2.7/site-packages/openerp/addons/web/controllers/main.py", line 702, in bootstrap_translations
translations_per_module[addon_name] = {'messages': _local_web_translations(f_name)}
File "/usr/lib/python2.7/site-packages/openerp/addons/web/controllers/main.py", line 494, in _local_web_translations
for x in po:
File "/usr/lib/python2.7/site-packages/babel/messages/catalog.py", line 552, in __iter__
for name, value in self.mime_headers:
File "/usr/lib/python2.7/site-packages/babel/messages/catalog.py", line 337, in _get_mime_headers
locale='en')))
File "/usr/lib/python2.7/site-packages/babel/dates.py", line 609, in format_datetime
locale = Locale.parse(locale)
File "/usr/lib/python2.7/site-packages/babel/core.py", line 284, in parse
language = get_global('language_aliases').get(language, language)
File "/usr/lib/python2.7/site-packages/babel/core.py", line 53, in get_global
_raise_no_data_error()
File "/usr/lib/python2.7/site-packages/babel/core.py", line 25, in _raise_no_data_error
raise RuntimeError('The babel data files are not available. '
RuntimeError: The babel data files are not available. This usually happens because you are using a source checkout from Babel and you did not build the data files. Just make sure to run "python setup.py import_cldr" before installing the library.

This erro appears only after http connection attempt, I had a blank screen in my navigator.

But now it's fine.

bidossessi commented on 2013-10-31 12:00

@ChrisDennis: it's happened to me too.
As I only use PG for openerp, my dirty workaround was to :
1. get a plain text dump of openerp databases using its database management interface,
2. Follow the wiki but NOT run the pg_upgrade
3. Start my PG server
4. Create the openerp user and start openerp,
5. Restore my databases from openerp.
YMMV

ChrisDennis commented on 2013-10-31 09:17

Thanks for your reply bidossessi.
This is the error message I got when I tried to upgrade to pg9.3:

pg_restore: creating TABLE ir_act_url
pg_restore: [archiver (db)] Error while PROCESSING TOC:
pg_restore: [archiver (db)] Error from TOC entry 190; 1259 59957 TABLE ir_act_url openerp
pg_restore: [archiver (db)] could not execute query: ERROR: column "name" in child table must be marked NOT NULL
Command was:
-- For binary upgrade, must preserve pg_type oid

I'll have another go when I have time.

bidossessi commented on 2013-10-31 06:23

@ChrisDennis. Openerp has no compatibility issues with the new postgresl. My suggestion is to backup your openerp databases, move to PG9.3, then restore.

ChrisDennis commented on 2013-10-30 11:42

OpenERP 7 wouldn't run after a system upgrade replaced postgresql 9.2 with 9.3 -- I had to downgrade to postgresql 9.2, and tell pacman to ignore upgrades to postgresql and postgresql-libs. (Yes, I tried upgrading my databases, but it gave an error with one of the openerp tables.)

Was that something I did wrong, or should openerp's dependencies be marked as requiring postgresql 9.2?

bidossessi commented on 2013-10-21 12:00

Updated to 2013/10/16 release.
Enjoy

bidossessi commented on 2013-08-12 17:06

Updated to latest nightly.

bidossessi commented on 2013-06-26 15:47

Updated to latest nightly.
Enjoy!

bidossessi commented on 2013-05-23 01:20

@mbrown: Thanks for the feedback. It should be fixed now.

mbrown commented on 2013-05-15 13:48

makepkg -si for version 7.0_20130502_232432-3 fails with :

install: cannot stat ‘$MYPATH/openerp/src/openerp.rc’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...

Removing the following line fixes the issue:

install -Dm 755 ${srcdir}/openerp.rc ${pkgdir}/etc/rc.d/openerp-server

Please update the PKGBUILD.

bidossessi commented on 2013-05-09 09:44

Dropped rc.d support,
changed a few settings in the service and conf.d files.

bidossessi commented on 2013-04-10 12:17

My apologies to users.
Internet and energy situation in my country has gone to hell.
I will try and keep a monthly update schedule.

mrechte commented on 2013-03-11 14:30

This version is no longer available, please update PKGBUILD.

Anonymous comment on 2013-02-19 18:47

Updated PKGBUILD (URL + md5sum) to 2013-02-19
http://pastebin.com/XqC6rDTq

bidossessi commented on 2013-02-11 08:39

@CanerCandan: I get no such error.

CanerCandan commented on 2013-02-11 08:16

After to have installed openerp 7.0_20130111_002202-1, you'll get an error while the starting due to /dev/log which is used by the logging manager. Just remove this parameter in the file "/usr/lib/python2.7/site-packages/openerp/netsvc.py" at the line 165 and it will work just fine.

bidossessi commented on 2013-01-25 16:19

@net147: I can send you the PKGBUILD for the latest 6.1 if you want, but I really can't maintain it as a package

net147 commented on 2013-01-24 01:46

Any chance to have the old version available as another package?

Anonymous comment on 2013-01-21 08:34

It's worked! Thank you.

bidossessi commented on 2013-01-12 01:58

As promised, tested and working.
Sorry about the lengthy version number. I still need to figure out how to use variables in PKGBUILD.
It works anyway, so enjoy :-)

bidossessi commented on 2013-01-12 01:54

As promised, tested and working.
Enjoy

bidossessi commented on 2013-01-11 07:24

Yes it will be updated some time before Sunday.
I'm considering wether to update this package to 7.0 or create a new one and leave this one for those who would want to stick with this version.

mbrown commented on 2013-01-09 21:05

Any chance this package will be updated to 7.0 soon?

bidossessi commented on 2012-11-29 15:38

Updated dependencies
python2-simplejson
python2-pychart
python2-imaging

mrechte commented on 2012-11-29 10:16

Hello. The following dependencies ought to be updated to their python2 version:

python-simplejson
python-pychart

bidossessi commented on 2012-10-20 07:35

Updated dependencies:
- python2-babel
- python2-reportlab

Fandekasp commented on 2012-10-18 02:07

Thx bidossessi. Now, there's python-babel and python-reportlab to upgrade :)

bidossessi commented on 2012-10-09 07:44

1. Updated dependencies as requested
2. Fixed pidfile creation in /run/openerp
3. Fixed rc.d script.
4. Fixed service file.
5. Finally added man files

Enjoy :-)

bidossessi commented on 2012-10-09 07:43

1. Updated dependencies as requested
2. Fixed pidfile creation in /run/openerp
3. Fixed rc.d script.
4. Fixed service file.

Enjoy :-)

Fandekasp commented on 2012-10-09 00:43

please switch dependency python-gdata to python2-gdata

zancarius commented on 2012-10-08 22:46

I have re-uploaded python-openid as python2-openid[1] in effort to comply with the Python packaging guidelines[2] and will be requesting a merge in the near future. If it isn't too much trouble, please update your dependencies accordingly! :)

[1] https://aur.archlinux.org/packages.php?ID=63285
[2] https://wiki.archlinux.org/index.php/Python_Package_Guidelines

Edit: Forgot to include appropriate links. Sorry about that!

zancarius commented on 2012-10-08 22:45

I have re-uploaded python-openid as python2-openid[1] in effort to comply with the Python packaging guidelines[2] and will be requesting a merge in the near future. If it isn't too much trouble, please update your dependencies accordingly! :)

rivas commented on 2012-09-19 18:56

Initd script fails for me. "$su - openerp / $openerp-server" works.

bidossessi commented on 2012-09-05 17:49

Added Systemd unit file and reworked initd script a bit.

bidossessi commented on 2012-06-06 10:52

Switched from python-webdav to python2-webdav

bidossessi commented on 2012-06-06 10:51

Swithed from python-webdav to python2-webdav

PaterSiul commented on 2012-06-05 09:10

Please switch from python-webdav to python2-webdav (https://aur.archlinux.org/packages.php?ID=59780)

Diego.Florez commented on 2012-04-13 08:08

That really made it works!
@bidosessi: Thank you so much for your work and support!

Diego.Florez commented on 2012-04-13 07:21

That really works!
@bidosessi: Thank you so much for your work and support!

bidossessi commented on 2012-04-13 02:10

I'm changing my strategy on how to solve this issue.
Moving modules inside site-packages to solve path inconsistencies

@diegoflorez: revert last changes to ARGS in /etc/conf.d/openerp-server
I've tested the package as a fresh install on another PC. It now works.

Diego.Florez commented on 2012-04-12 14:52

@bidossessi Thank you so much for your response and your work in this package, it has solved the last error.

But now, when I am trying to create a database, I get this error:

2012-04-12 14:47:29,204 8952 ERROR newDataBase openerp.service.web_services: CREATE DATABASE failed:
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/openerp/service/web_services.py", line 69, in _initialize_db
update_module=True)[1]
File "/usr/lib/python2.7/site-packages/openerp/pooler.py", line 39, in restart_pool
registry = RegistryManager.new(db_name, force_demo, status, update_module, True)
File "/usr/lib/python2.7/site-packages/openerp/modules/registry.py", line 160, in new
openerp.modules.load_modules(registry.db, force_demo, status, update_module)
File "/usr/lib/python2.7/site-packages/openerp/modules/loading.py", line 298, in load_modules
loaded_modules, processed_modules = load_module_graph(cr, graph, status, perform_checks=(not update_module), report=report)
File "/usr/lib/python2.7/site-packages/openerp/modules/loading.py", line 170, in load_module_graph
init_module_models(cr, package.name, models)
File "/usr/lib/python2.7/site-packages/openerp/modules/module.py", line 378, in init_module_models
result = obj._auto_init(cr, {'module': module_name})
File "/usr/lib/python2.7/site-packages/openerp/osv/orm.py", line 2973, in _auto_init
default = self._defaults[k](self, cr, SUPERUSER_ID, context)
File "/usr/openerp/addons/base/res/res_company.py", line 250, in _get_logo
return open(os.path.join( tools.config['root_path'], 'addons', 'base', 'res', 'res_company_logo.png'), 'rb') .read().encode('base64')
IOError: [Errno 2] No existe el fichero o el directorio: '/usr/lib/python2.7/site-packages/openerp/addons/base/res/res_company_logo.png'
Exception in thread Thread-4:
Traceback (most recent call last):
File "/usr/lib/python2.7/threading.py", line 552, in __bootstrap_inner
self.run()
File "/usr/lib/python2.7/threading.py", line 505, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/lib/python2.7/site-packages/openerp/service/web_services.py", line 91, in _initialize_db
cr.close()
File "/usr/lib/python2.7/site-packages/openerp/sql_db.py", line 151, in wrapper
raise psycopg2.OperationalError(msg)
OperationalError: Unable to use a closed cursor.

2012-04-12 14:47:29,624 8952 ERROR ? openerp.netsvc: 2
No existe el fichero o el directorio

bidossessi commented on 2012-04-12 13:40

@diegoflorez, @JohanSJA
Quickfix: Append "--addons-path=/usr/openerp/addons" to the ARGS line in /etc/conf.d/openerp-server

I will upload an updated source right now.

Diego.Florez commented on 2012-04-12 05:04

When I try to connect from openerp-client it detect the conecction to server, but when I try to create a new DataBase fails, Server log show following:

2012-04-12 04:58:37,538 2674 INFO ? openerp: OpenERP version 6.1-1
2012-04-12 04:58:37,539 2674 INFO ? openerp: addons paths: /usr/lib/python2.7/site-packages/openerp/addons
2012-04-12 04:58:37,539 2674 INFO ? openerp: database hostname: localhost
2012-04-12 04:58:37,539 2674 INFO ? openerp: database port: 5432
2012-04-12 04:58:37,540 2674 INFO ? openerp: database user: openERP
2012-04-12 04:58:37,540 2674 INFO ? openerp.service.netrpc_server: starting NET-RPC service on 0.0.0.0:8070
2012-04-12 04:58:37,541 2674 INFO ? openerp.netsvc: Starting 1 services
2012-04-12 04:58:37,593 2674 INFO ? openerp.wsgi.core: HTTP service (werkzeug) running on 0.0.0.0:8069
2012-04-12 04:58:37,873 2674 INFO ? openerp.addons.web: embedded mode
2012-04-12 04:58:37,901 2674 INFO ? openerp: OpenERP server is running, waiting for connections...
2012-04-12 05:00:09,284 2674 INFO template1 openerp.service.web_services: CREATE DATABASE newDataBase
2012-04-12 05:00:09,295 2674 CRITICAL newDataBase openerp.modules.db: File not found: 'base.sql' (provided by module 'base').
2012-04-12 05:00:09,296 2674 ERROR newDataBase openerp.service.web_services: CREATE DATABASE failed:
Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/openerp/service/web_services.py", line 63, in _initialize_db
openerp.modules.db.initialize(cr) # TODO this should be removed as it is done by pooler.restart_pool.
File "/usr/lib/python2.7/site-packages/openerp/modules/db.py", line 49, in initialize
raise IOError(m)
IOError: File not found: 'base.sql' (provided by module 'base').
2012-04-12 05:00:10,314 2674 ERROR ? openerp.netsvc: File not found: 'base.sql' (provided by module 'base').

Diego.Florez commented on 2012-04-12 05:00

I am having exactly the same trouble than JohanSJA:
"...I started the openerp-server service from terminal and browse to "http://localhost:8069" from web browser. However, what I see in the browser is only a blank page. And the following is the log from the terminal..."

Diego.Florez commented on 2012-04-12 04:22

I am having exactly the same trouble than JohanSJA:
"...I started the openerp-server service from terminal and browse to "http://localhost:8069" from web browser. However, what I see in the browser is only a blank page. And the following is the log from the terminal..."

bidossessi commented on 2012-04-10 15:27

Updated to fix python2-lxml dependency.
As for the openerp-web working, I use it routinely everyday, so I'd say yes.

Anonymous comment on 2012-04-09 21:53

And also is the openerp-web working at the moment? I started the openerp-server service from terminal and browse to "http://localhost:8069" from web browser. However, what I see in the browser is only a blank page. And the following is the log from the terminal.

[johansja@jsja-14 openerp]$ openerp-server
2012-04-09 21:50:43,068 26977 INFO ? openerp: OpenERP version 6.1-1
2012-04-09 21:50:43,068 26977 INFO ? openerp: addons paths: /usr/lib/python2.7/site-packages/openerp/addons
2012-04-09 21:50:43,068 26977 INFO ? openerp: database hostname: localhost
2012-04-09 21:50:43,068 26977 INFO ? openerp: database port: 5432
2012-04-09 21:50:43,068 26977 INFO ? openerp: database user: johansja
2012-04-09 21:50:43,069 26977 INFO ? openerp.service.netrpc_server: starting NET-RPC service on 0.0.0.0:8070
2012-04-09 21:50:43,069 26977 INFO ? openerp.netsvc: Starting 1 services
2012-04-09 21:50:43,098 26977 INFO ? openerp.wsgi.core: HTTP service (werkzeug) running on 0.0.0.0:8069
2012-04-09 21:50:43,259 26977 INFO ? openerp.addons.web: embedded mode
2012-04-09 21:50:43,269 26977 INFO ? openerp: OpenERP server is running, waiting for connections...
2012-04-09 21:50:57,714 26977 INFO ? werkzeug: 127.0.0.1 - - [09/Apr/2012 21:50:57] "GET / HTTP/1.1" 301 -
2012-04-09 21:50:57,719 26977 INFO ? werkzeug: 127.0.0.1 - - [09/Apr/2012 21:50:57] "GET /web/webclient/home HTTP/1.1" 200 -
2012-04-09 21:50:57,741 26977 INFO ? werkzeug: 127.0.0.1 - - [09/Apr/2012 21:50:57] "GET /web/webclient/css HTTP/1.1" 304 -
2012-04-09 21:50:57,743 26977 INFO ? werkzeug: 127.0.0.1 - - [09/Apr/2012 21:50:57] "GET /web/webclient/js HTTP/1.1" 304 -
2012-04-09 21:50:57,846 26977 INFO ? werkzeug: 127.0.0.1 - - [09/Apr/2012 21:50:57] "GET /web/static/src/img/favicon.ico HTTP/1.1" 404 -

Anonymous comment on 2012-04-09 21:48

It seems like python2-lxml is needed as well. Not sure if python-lxml can be obseleted in this case.

stativ commented on 2012-03-27 16:44

Merged openerp-server into openerp.

stativ commented on 2012-03-27 16:43

Merged openerp-web into openerp.

bidossessi commented on 2012-03-21 19:28

Added python-imaging as a dep.
I must admit I missed it because it was already installed on my server

aricaldeira commented on 2012-03-20 23:05

First of all, thank you so much for this package!

I was trying to create one myself, but you got it right first :)

Please, add python-imaging to the dependencies, otherwise, you'll get the following error message:


No handlers could be found for logger "openerp.report.render"

Thanks again!

bidossessi commented on 2012-03-12 09:40

Obsoletes openerp-server and openerp-web packages in AUR

bidossessi commented on 2012-03-12 08:46

This package has now been merged into the openerp server.
https://aur.archlinux.org/packages.php?ID=57534

bidossessi commented on 2012-03-12 08:42

obsolete
Please use https://aur.archlinux.org/packages.php?ID=57534

bidossessi commented on 2012-02-01 07:54

needs python2-mako and python2-cherrypy
please update PKGBUILD

I've taken over openerp-server and openerp-client. I can offer a working tarball if you wish

bidossessi commented on 2012-01-13 09:13

I'm adopting this package for now.
I added an rc.d script and a few other changes to the PKGBUILD to make it easier to deploy
I also updated the dependencies to reflect the latest changes in package names (e.g. python-vobject -> python2-vobject)

RazZziel commented on 2011-12-28 13:54

Lacks python2-mako dependency:

> ImportError: No module named mako

RazZziel commented on 2011-12-28 10:21

Lacks python-mako dependency:

> ImportError: No module named mako

Anonymous comment on 2011-12-07 15:21

Sorry but the package from aur repo have not a populate.sh script so i can't install the good pycherry lib.
Or may be he's hide somewhere?

Finally it's work with the simple python way (python2 setup.py install) but it's not a good way for update control.

Anonymous comment on 2011-12-07 14:13

oops.
https://bugs.launchpad.net/openobject-client-web/+bug/677467 hmm.

Anonymous comment on 2011-12-07 13:32

Thanks for the answer, it's not fixed but this topic present an another way to install openerp-web.

Anonymous comment on 2011-12-07 11:16

openerp-web cherrypy >= 3.2 not supporting. http://www.openerp.com/forum/topic23011.html

Anonymous comment on 2011-12-07 11:07

Yaourt can't find cherrypy<=3.1.2
The cherrypy's version in repo is 3.2, if I force to install whith this version I have a critical error after installing openerp-web:
AttributeError: 'module' object has no attribute 'Tool'.

How to fix it?

Anonymous comment on 2011-09-15 17:43

As vorbote says, there's missing dependency : python2-setuptools

Anonymous comment on 2011-08-26 21:54

released version 6.0.3

Anonymous comment on 2011-08-26 21:54

released version 6.0.3

vorbote commented on 2011-08-15 16:45

Uninstallable with an AUR helper. Asks for non-existent setuptools instead of python2-setuptools.

Anonymous comment on 2011-05-10 08:00

raw, midas, thanks.

raw commented on 2011-05-09 07:29

pkgname=openerp-web
pkgver=6.0.2
pkgrel=1
pkgdesc="OpenERP web (python2)"
url="http://openerp.com/"
arch=('i686' 'x86_64')
license=(GPL3)
depends=('python2' 'python-pytz'
'python-formencode' 'python-babel' 'python-dateutil'
'python-mako' 'cherrypy<=3.1.2' 'python-simplejson')
source=(
http://www.openerp.com/download/stable/source/$pkgname-$pkgver.tar.gz
openerp-web.rc
)
md5sums=('b7b8fea249c946e72374c24882a860b2'
'b517fa19d0263ee18edd2ad1c8c7de90')

build() {
cd "$srcdir/$pkgname-$pkgver"

mkdir ${pkgdir}/etc/{rc.d,openerp} -p
mkdir ${pkgdir}/usr/doc/openerp-web/ -p
#TODO fixed daemonize =_=. RUN AS SCREEN?
install -Dm 755 ${srcdir}/openerp-web.rc ${pkgdir}/etc/rc.d/openerp-web

python2 setup.py install --root=$pkgdir
mv ${pkgdir}/usr/addons ${pkgdir}/usr/lib/python2.*/site-packages/
cp ${pkgdir}/usr/openobject ${pkgdir}/usr/lib/python2.*/site-packages/ -r
rm -rf ${pkgdir}/usr/openobject
cp ${pkgdir}/usr/doc/openerp-web.cfg ${pkgdir}/etc/openerp/

cp ${pkgdir}/usr/doc/{LICENSE.txt,ChangeLog,openerp-web.cfg,packaging.txt} ${pkgdir}/usr/doc/openerp-web/
rm ${pkgdir}/usr/doc/{LICENSE.txt,ChangeLog,openerp-web.cfg,packaging.txt}

}

updated for 6.0.2. the web interface still throws a lot of errors if using cherrypy newer than 3.1.2, so i added that as requirement.

mdias commented on 2011-04-20 10:54

depends on python2-pytz, not python-pytz

mdias commented on 2011-04-20 10:39

Also, shouldn't "python-imaging" be in optdepends instead of "python-pil"?

mdias commented on 2011-04-20 10:36

the following is also required:
python2-yaml and python2-psycopg2

raw commented on 2011-03-15 14:49

python-mako is required to run openerp-server. please add it.

L42y commented on 2011-03-11 03:06

i'm not a good maintainer, disown it

L42y commented on 2011-02-07 20:15

hi, mark. maybe you like to work with me in this way: http://pkgbuild.org/openerp/openerp-server

Anonymous comment on 2011-02-07 14:37

missing dependency community/python-dateutil

Anonymous comment on 2011-02-07 13:24

opt deps are not correct anymore
openerp-server.install is missing (setting openerp.conf and rc.d scripts)

if you like we take care of this together

Anonymous comment on 2010-12-06 13:41

ok, its free for you to maintain!

L42y commented on 2010-12-05 22:16

5.0.15 is out, if you don't have much time to maintian it, and if you like to, transfer it to me.

L42y commented on 2010-12-05 21:54

5.0.15 is out, if you don't have much time to maintian it, and if you like to, transfer it to me.

Anonymous comment on 2010-11-01 11:47

thanks I take care of it ;-)

tocer commented on 2010-10-27 01:25

welcome anyone adopt the package

tocer commented on 2010-06-18 01:54

coffeeowl:

Sorry for reply so late. I have no better idea about your patch of the PKGBUILD. And I should have no enough time to maintain it in the future. Do you like adopt it?

Anonymous comment on 2010-06-14 07:40

Done. http://aur.pastebin.com/XnAW22G3
I should say I'm not good at shell scripting, so I have adopted one that comes with mysql :-) But still there can be some bugs.
One of them I know - as you can see I forcibly change ownership of the /etc/openerp-server.conf to openerp user(postgres).
if [ -e $ERP_SERVER_OPTFILE ]; then
chown $ERP_USER:$ERP_GROUP $ERP_SERVER_OPTFILE
fi
I guess it's definitely not good, but I don't know how to make this file readable to the openerp-server any other way.

tocer commented on 2010-06-13 22:16

coffeeowl:
it's a good idea. you can post the PKGBUILD in the pastbin. thank you.

Anonymous comment on 2010-06-13 14:57

Hi tocer,
I think it would be nice to have this server act as an daemon (I mean /etc/rc.d way).
I have modified PKGBUILD and added some files to implement this functionality. If you are interested I can send them to you.

tocer commented on 2010-04-02 15:20

fixed. thanks yannick555

Anonymous comment on 2010-04-02 14:35

I managed to install openerp-server, after a manual hack to install pydot.

Nevertheless, the generated file in /usr/bin/openerp-server is incorrect, it changes to directory /tmp/yaourt-xxxxx/... which is not right.

The right one should be /usr/lib/python2.6/site-packages/openerp-server

tocer commented on 2010-03-25 03:31

python25 -> python26.

I don't know if anybody need openerp package with python25 dependency?