Package Details: opengothic 0.37-1

Git Clone URL: https://aur.archlinux.org/opengothic.git (read-only, click to copy)
Package Base: opengothic
Description: Open source remake of Gothic 2: Night of the raven
Upstream URL: https://github.com/Try/OpenGothic
Licenses: MIT
Conflicts: bullet
Submitter: CReimer
Maintainer: CReimer
Last Packager: CReimer
Votes: 1
Popularity: 0.33
First Submitted: 2021-02-13 20:04
Last Updated: 2021-04-19 17:00

Latest Comments

CReimer commented on 2021-02-14 20:09

Thank you. I wasn't aware of that part of the VCS package guidelines and I also added the missing makedepends

yochananmarqos commented on 2021-02-14 19:26

Please follow VCS package guidelines for submodules.

This is missing glslang and libglvnd from makedepends():

CMake Error at lib/Tempest/Engine/CMakeLists.txt:116 (message):
  glslangValidator required
-- Could NOT find OpenGL (missing: OPENGL_opengl_LIBRARY OPENGL_glx_LIBRARY OPENGL_INCLUDE_DIR)
OPENGL NOT FOUND

See Cmake package guidelines, -DCMAKE_BUILD_TYPE='None' should normally be used.

Use -DOpenGL_GL_PREFERENCE='GLVND':

  OpenGL_GL_PREFERENCE has not been set to "GLVND" or "LEGACY", so for
  compatibility with CMake 3.10 and below the legacy GL library will be used.

This not only conflicts with bullet, but also libsquish and physfs. To avoid that, they can be added as dependencies and conflicting files removed.

Using -DBUILD_SHARED_LIBS='OFF' doesn't make any difference, but -DPHYSFS_BUILD_SHARED='OFF' does.

There are no empty directories, no need to disable any default options.

Improved PKGBUILD