Package Details: openjdk12-doc 12.0.2.u10-3

Git Clone URL: https://aur.archlinux.org/java-12-openjdk.git (read-only, click to copy)
Package Base: java-12-openjdk
Description: OpenJDK Java 12 documentation
Upstream URL: https://openjdk.java.net/
Licenses: custom
Provides: openjdk12-doc
Submitter: Muflone
Maintainer: Muflone
Last Packager: Muflone
Votes: 2
Popularity: 0.003087
First Submitted: 2021-11-28 19:25 (UTC)
Last Updated: 2023-07-09 18:24 (UTC)

Dependencies (23)

Required by (0)

Sources (9)

Latest Comments

Luca91 commented on 2023-03-07 20:16 (UTC)

Hello,

the sha256 changed for the jdk-12.0.2+10.tar.gz file.

The new sha256 is 30b8915a228df6bda0ef556494a6b886e59c46724c7a339b2ba5f97021bed709

Please update the PKGBUILD accordingly.

Thanks a lot,

Luca

mindless_canary commented on 2022-04-26 06:25 (UTC)

The change of @aetherherne is indeed necessary. Could that please be fixed?

aetherherne commented on 2022-03-26 03:08 (UTC)

Would it be possible to change line 58 of the PKGBUILD from

export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -vE '8-|9-|10-' -m 1)"

to

export JAVA_HOME="/usr/lib/jvm/$(archlinux-java status | tail -n +2 | sort | cut -d ' ' -f 3 | sort -nr -k 2 -t '-' | grep -E '11-|12-' -m 1)"

as the package fails to build for other versions of java with error as follows:

configure: Found potential Boot JDK using configure arguments
configure: Potential Boot JDK found at /usr/lib/jvm/java-17-openjdk is incorrect JDK version (openjdk version "17.0.3" 2022-04-19); ignoring
configure: (Your Boot JDK version must be one of: 11 12)
configure: error: The path given by --with-boot-jdk does not contain a valid Boot JDK
configure exiting with result code 1