Package Details: openlp 3.0.2-2

Git Clone URL: (read-only, click to copy)
Package Base: openlp
Description: Church presentation software.
Upstream URL:
Keywords: bible church pdf presentation projection song video
Licenses: GPLv2
Submitter: floft
Maintainer: macxcool
Last Packager: macxcool
Votes: 18
Popularity: 0.30
First Submitted: 2015-08-11 00:27 (UTC)
Last Updated: 2023-07-12 22:10 (UTC)

Pinned Comments

macxcool commented on 2023-07-21 11:37 (UTC)

According to the OpenLP devs, python-pillow has been removed from the code and will not be a dependency for the next release.

macxcool commented on 2023-07-13 16:22 (UTC) (edited on 2023-07-26 23:23 (UTC) by macxcool)

Python Pillow (python-pillow) 10.0 breaks OpenLP, so the version of python-pillow is set to <10.0. You can use 'downgrade' to install a pre 10.0 version and optionally mark it as ignored in your pacman.conf file.

If you don't want to mark it as ignored in pacman.conf, just add --ignore python-pillow to your command line. Most (all?) AUR helpers will just pass this on to pacman.

Latest Comments

1 2 3 4 5 6 7 Next › Last »

greenginger commented on 2023-09-22 04:24 (UTC)

for me this additional dependencies were missing: python-flask, python-flask-cors, python-webob, python-vlc, python-pymediainfo

zeroconf commented on 2023-08-15 19:20 (UTC) (edited on 2023-08-15 19:36 (UTC) by zeroconf)

Would propose AppImage format - e.g. pCloud is installed via AUR from AppImage. Then it will be binary with all dependencies. Another option is just create openlp-bin package, could be additionally as some people might prefer compiling. Hopefully is possible to convince OpenLP creators to create an AppImage file, preferally with update feature. Currently I see only distro-specific packages at OpenLP download page but AppImage is suitable for many Linux distros with almost no dependencies (only libc AFAIK) and could be used as regular user without need of superuser permissions. When to use AppImage, still there is possible to create AUR package for convenient installation, upgrade, as mentioned pCloud has been done. This could be useful if AppImage does not have update feature.

macxcool commented on 2023-08-12 16:53 (UTC)

What do people think about setting up a virtual environment with pipx and injecting pillow 9.5 into it. That works for me with:

pipx install openlp
pipx inject pillow pillow==9.5.0

It should be possible to do this in the pkg folder when building, copying the whole thing to /opt and letting that be the openlp version until this whole python-pillow thing is resolved. Is this just a really bad idea?

zeroconf commented on 2023-08-05 21:13 (UTC) (edited on 2023-08-05 21:20 (UTC) by zeroconf)

@Spinnekop tried to install with python-pillow95. It started to install. Endless compiling was too overwhelming for me even with 8-core i7 CPU.... Also lots of dependencies for compiling were installed... Besides, such overwhelming recompiling will happen with every OpenLP update... I canceled installation, removed residues and will wait binary package, openlp-bin usually. I see Ubuntu, Fedora, Debian packages on official download site. I guess also these can be used for binary package. Also AppImage, Flatpak version are expected - these ideas have been already posted to OpenLP developers via GitLab. Seems like the python-pillow issue have been solved.

Spinnekop commented on 2023-07-30 13:11 (UTC)

@zeroconf have you tried it with python-pillow95?

pacman won't work because openlp is an AUR package

zeroconf commented on 2023-07-30 09:58 (UTC) (edited on 2023-08-05 21:04 (UTC) by zeroconf)

Sorry to mention but impossible to install OpenLP.

First of all, trying to ignore python-pillow, still it requires that package:

yay -Sy openlp --ignore=python-pillow
:: There are 3 providers available for python-pillow<10.0:
:: Repository AUR
    1) python-pillow-git 2) python-pillow-simd 3) python-pillow95 

Enter a number (default=1): 

pacman has no openlp package:

sudo pacman -Sy openlp --ignore=python-pillow
error: target not found: openlp

Unfortunately there is no Flatpak or even no AppImage version of OpenLP. Hopefully there will be fixed version available soon.

game commented on 2023-07-27 14:21 (UTC)

@maxcool Thank you for answering this noob question. Yes that is the case, I haven't had base-devel installed. Up to now pamac fetched cmake & Co on it's own.

macxcool commented on 2023-07-26 23:22 (UTC)

@game Do you have the base-devel installed? It's generally assumed when installing AUR packages.

game commented on 2023-07-26 23:14 (UTC)

I needed to install bison for this pkgbuild to work. Is this a new build dependency or is my system strange?

macxcool commented on 2023-07-21 11:37 (UTC)

According to the OpenLP devs, python-pillow has been removed from the code and will not be a dependency for the next release.