Package Details: openlp 2.4.6-5

Git Clone URL: https://aur.archlinux.org/openlp.git (read-only, click to copy)
Package Base: openlp
Description: Church presentation software.
Upstream URL: http://openlp.org/
Licenses: GPLv2
Submitter: floft
Maintainer: thelinuxguy
Last Packager: thelinuxguy
Votes: 17
Popularity: 0.004616
First Submitted: 2015-08-11 00:27 (UTC)
Last Updated: 2020-12-30 15:50 (UTC)

Pinned Comments

thelinuxguy commented on 2016-08-24 10:10 (UTC) (edited on 2022-01-11 16:55 (UTC) by thelinuxguy)

Not compatible with python 3.10

Your options are: do not update python or uninstall OpenLP until the next major release. This can happen with a rolling release...

If you run into issues about missing GPG keys, you will need to manually add them to your keyring or skip GPG checks (makepkg --skippgpchecks). Please refer to the wiki[1] for more information.

[1] https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

Latest Comments

1 2 3 4 Next › Last »

bage commented on 2022-03-13 21:16 (UTC)

I suggest to depend on python39 or to update to the current RC 2.9.4.

ArchChem commented on 2022-01-11 11:57 (UTC)

The building of the package fails due to the dependency python<3.10 which can not be found anymore.

Spinnekop commented on 2021-12-27 17:05 (UTC) (edited on 2021-12-31 11:33 (UTC) by Spinnekop)

@thelinuxguy "I'll create an issue upstream" - good luck with that - he hasn't answered emails and the forum is now offline.... If you can come up with a fix it would be greatly appreciated!

thelinuxguy commented on 2021-12-22 23:57 (UTC)

@clixer it looks like under python 3.10 the various UI components aren't initialized in the correct order. I played around a little but I'm afraid that's something that's not going to be fixed using a simple patch... I'll create an issue upstream

clixer commented on 2021-12-14 17:55 (UTC) (edited on 2021-12-14 17:56 (UTC) by clixer)

Unfortunately it doesn't seem quite as straightforward as a drop-in MAKEPKG update. I can build it with python3.10 and get the package installed but on start I run into this issue.

AttributeError: 'PreviewController' object has no attribute 'grid'

joelchrono12 commented on 2021-12-14 15:33 (UTC)

@ClawOfLight Thanks for letting me know, I thought that was the case, but still, the problem is I haven't been able to update my system because of the python update. I hope it gets fixed soon enough.

Sorry for the flag too, I am pretty new here but that's no excuse since I failed to realize that this version was latest stable one.

thebiblelover7 commented on 2021-12-14 08:06 (UTC)

@ClawOfLight Sorry for the misunderstanding. Do you know if we can at least unbind the python version? Or is it still not supported?

ClawOfLight commented on 2021-12-14 07:56 (UTC) (edited on 2021-12-14 07:57 (UTC) by ClawOfLight)

2.4.6 is the latest stable version, everything else has been alpha or beta. The next stable will me a major 3.x release :)

Please don't flag out of date for unstable releases!

joelchrono12 commented on 2021-12-14 01:16 (UTC)

This package requires to be updated, my system wants to update python3 but is unable to do so because OpenLP requires Python's version to be under 3.10.

Also, there are newer versions available since 2.4.6, could it be possible for this package to be updated?

game commented on 2021-09-08 16:52 (UTC) (edited on 2021-09-08 17:24 (UTC) by game)

I wasn't able to show PDFs after installing mupdf. Only after some research I found out that I need mupdf-tools instead. Can you please update the dependencies? btw: openlp talks about mudraw, but that's outdated and has been moved into the command mutool draw

edit: mupdf is not needed for presenting PDFs

edit: ghostscript can also be used as a PDF renderer