Package Details: openlp 3.0.2-2

Git Clone URL: https://aur.archlinux.org/openlp.git (read-only, click to copy)
Package Base: openlp
Description: Church presentation software.
Upstream URL: http://openlp.org/
Keywords: bible church pdf presentation projection song video
Licenses: GPLv2
Submitter: floft
Maintainer: macxcool
Last Packager: macxcool
Votes: 18
Popularity: 0.015119
First Submitted: 2015-08-11 00:27 (UTC)
Last Updated: 2023-07-12 22:10 (UTC)

Pinned Comments

macxcool commented on 2023-07-21 11:37 (UTC)

According to the OpenLP devs, python-pillow has been removed from the code and will not be a dependency for the next release.

macxcool commented on 2023-07-13 16:22 (UTC) (edited on 2023-07-26 23:23 (UTC) by macxcool)

Python Pillow (python-pillow) 10.0 breaks OpenLP, so the version of python-pillow is set to <10.0. You can use 'downgrade' to install a pre 10.0 version and optionally mark it as ignored in your pacman.conf file.

If you don't want to mark it as ignored in pacman.conf, just add --ignore python-pillow to your command line. Most (all?) AUR helpers will just pass this on to pacman.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

clixer commented on 2021-12-14 17:55 (UTC) (edited on 2021-12-14 17:56 (UTC) by clixer)

Unfortunately it doesn't seem quite as straightforward as a drop-in MAKEPKG update. I can build it with python3.10 and get the package installed but on start I run into this issue.

AttributeError: 'PreviewController' object has no attribute 'grid'

joelchrono12 commented on 2021-12-14 15:33 (UTC)

@ClawOfLight Thanks for letting me know, I thought that was the case, but still, the problem is I haven't been able to update my system because of the python update. I hope it gets fixed soon enough.

Sorry for the flag too, I am pretty new here but that's no excuse since I failed to realize that this version was latest stable one.

thebiblelover7 commented on 2021-12-14 08:06 (UTC)

@ClawOfLight Sorry for the misunderstanding. Do you know if we can at least unbind the python version? Or is it still not supported?

ClawOfLight commented on 2021-12-14 07:56 (UTC) (edited on 2021-12-14 07:57 (UTC) by ClawOfLight)

2.4.6 is the latest stable version, everything else has been alpha or beta. The next stable will me a major 3.x release :)

Please don't flag out of date for unstable releases!

joelchrono12 commented on 2021-12-14 01:16 (UTC)

This package requires to be updated, my system wants to update python3 but is unable to do so because OpenLP requires Python's version to be under 3.10.

Also, there are newer versions available since 2.4.6, could it be possible for this package to be updated?

game commented on 2021-09-08 16:52 (UTC) (edited on 2021-09-08 17:24 (UTC) by game)

I wasn't able to show PDFs after installing mupdf. Only after some research I found out that I need mupdf-tools instead. Can you please update the dependencies? btw: openlp talks about mudraw, but that's outdated and has been moved into the command mutool draw

edit: mupdf is not needed for presenting PDFs

edit: ghostscript can also be used as a PDF renderer

macxcool commented on 2021-03-19 15:12 (UTC)

@thelinuxguy 2.9.2 is a beta release of the development version, not a stable release. Can you please unflag it. @sweenu Please don't flag this 'out-of-date' for development releases.

macxcool commented on 2021-02-01 21:21 (UTC)

@sweenu The 'new' versions are not releases. Please don't mark this out-of-date until the new 3.0 release is done.

luspi commented on 2020-12-11 18:24 (UTC)

Build fails as python is now at version 3.9. Replacing the references to python3.8 to python3.9 fixes it.

hashstat commented on 2020-09-12 02:27 (UTC)

It looks like vlc is required, not optional. openlp crashed without it. The stack trace referenced libvlc.