Package Details: openmc-git v0.14.0.r5.g9830efaf2-3

Git Clone URL: https://aur.archlinux.org/openmc-git.git (read-only, click to copy)
Package Base: openmc-git
Description: The OpenMC project aims to provide a fully-featured Monte Carlo particle transport code based on modern methods.
Upstream URL: https://github.com/openmc-dev/openmc
Licenses: MIT
Provides: openmc-git
Submitter: gavmanz
Maintainer: gavmanz (aslakstubsgaard, LukeLabrie)
Last Packager: LukeLabrie
Votes: 1
Popularity: 0.94
First Submitted: 2020-05-19 01:40 (UTC)
Last Updated: 2024-07-18 10:36 (UTC)

Latest Comments

1 2 Next › Last »

LukeLabrie commented on 2024-07-18 11:48 (UTC)

@pryme-svg, thanks. This has been corrected.

@Kunda, there is not a strict dependency on freecad. This package provides a dagmc-enabled version of openmc, along with CAD_to_OpenMC, a package for converting CAD files to openmc-readable meshes. When I initially wrote this PKGBUILD, my goal was to provide the full suite of tools for the CAD -> OpenMC workflow. Strictly speaking however, it is not a dependency. Perhaps I'll remove it on the next version.

pryme-svg commented on 2024-07-17 17:13 (UTC)

The checksum is incorrect for the openmc.sh file, and I believe python-build and python-installer should also be included as makedeps

Kunda commented on 2024-07-13 17:18 (UTC)

Quick question: I searched the codebase and couldn't find any mention of freecad. Why is there a dependency on it ? TIA

CarlWillis commented on 2024-06-27 23:06 (UTC)

In my attempted installation today, validation for openmc.sh failed (the MD5 checksum is incorrect). Thanks for making this available and I look forward to using OpenMC on Windows.

LukeLabrie commented on 2024-05-02 08:25 (UTC)

Interesting. Well this currently provides 0.14.0 so I'm not sure why pip is complaining on your system. The error message should provide more detail on the conflict.

Shinmen commented on 2024-05-01 20:58 (UTC)

@LukeLabrie i don't have another version on system, I think, above the result of which openmc

which openmc /opt/openmc/bin/openmc

LukeLabrie commented on 2024-05-01 15:13 (UTC)

@Shinmen it sounds like you have another version of openmc on your system that's being prioritized over the one provided by this PKGBUILD. What do you see when you run which openmc?

Shinmen commented on 2024-04-15 16:27 (UTC)

@LukeLabrie, yes I receivei the following message when I try to install the plotter using pip, The conflict is caused by: openmc-plotter 0.4.0 depends on openmc>0.12.2

LukeLabrie commented on 2024-04-15 11:59 (UTC)

@Shinmen I don't think openmc-plotter is available on the AUR yet, but it's installable through pip. Are you having trouble using it along with this AUR version of openmc?

LukeLabrie commented on 2024-04-15 11:54 (UTC) (edited on 2024-04-15 11:56 (UTC) by LukeLabrie)

@WarmConsidering I think you're right about Cython and the python builder and installer tools, for the python layer at least. I will add them as dependencies. They are dependencies of moab, so it should be resolved if you're using an AUR helper like yay.

OpenMC does not directly depend on eigen, it's an upstream dependency through moab. If you've installed moab-git through the AUR it should be available.

FYI, if you're installing these with makepkg -si, it will not be able to resolve dependencies from the AUR since it uses pacman.