Package Details: openni-git 20130205-2

Git Clone URL: https://aur.archlinux.org/openni-git.git (read-only)
Package Base: openni-git
Description: The OpenNI Framework provides the interface for physical devices and for middleware components
Upstream URL: http://www.openni.org/
Licenses: GPL
Conflicts: openni
Provides: openni
Submitter: bugix
Maintainer: Sandmann
Last Packager: Sandmann
Votes: 19
Popularity: 0.000000
First Submitted: 2011-02-12 16:54
Last Updated: 2015-06-27 13:53

Latest Comments

bchretien commented on 2014-04-13 09:43

@Sandmann: you could use:

git describe --abbrev=0 --tags | cut -d'-' -f2

Sandmann commented on 2014-02-08 14:09

@bchretien, sure, I can include the pkg-config file. However, I'm wondering from where to get the version number (i.e. 1.5.7.10) as the package is built from the latest sources.

bchretien commented on 2014-02-02 20:44

Hi, can you consider including pkg-config file?

Updated PKGBUILD + file available here: http://goo.gl/u2h4HA

Sandmann commented on 2013-12-08 21:45

Patch included. Thank you.

zanegrey commented on 2013-12-08 08:19

This package is missing the jni lib. Here is a patch to fix it.

74c74
< install libnimCodecs.so libnimMockNodes.so libnimRecorder.so libOpenNI.so "${pkgdir}/usr/lib"
---
> install libnimCodecs.so libnimMockNodes.so libnimRecorder.so libOpenNI.so libOpenNI.jni.so "${pkgdir}/usr/lib"

Sandmann commented on 2013-02-05 13:35

Thanks for the hint. The package now depends on "mesa".

Anonymous comment on 2013-02-05 11:52

You should add "mesa" package to dependencies.
It contains GL/glx.h which is needed for building SimpleNIViewer.

zootboy commented on 2012-12-08 19:04

@sen.cenan
I ran into this same issue. You need to have your locale set to UTF-8.

https://wiki.archlinux.org/index.php/Locale#US_English_example

Follow the "US english example" and the "Setting system-wide locale" sections.

Anonymous comment on 2012-12-02 20:32

I am getting BOMs (byte ordering mark) after the licensing comments in some of the C sharp files, causing the build to fail. I tried to remove it from source files manually, but it still doesn't work. Anyone knows what's going on here? Thanks a lot.

ex:
../../../../../Wrappers/OpenNI.net/AntiFlickerCapability.cs(22,0): error CS1525: Unexpected symbol `?'
../../../../../Wrappers/OpenNI.net/AssemblyInfo.cs(22,0): error CS1525: Unexpected symbol `?'
../../../../../Wrappers/OpenNI.net/AudioMetaData.cs(22,0): error CS1525: Unexpected symbol `?'

Sandmann commented on 2012-05-17 22:44

Thank you. Problem fixed.

All comments