Package Details: openni2-git 2.2.beta.r25.g1fce8ed-6

Git Clone URL: https://aur.archlinux.org/openni2-git.git (read-only)
Package Base: openni2-git
Description: Framework for sensor-based Natural Interaction (git version)
Upstream URL: https://github.com/occipital/OpenNI2/
Keywords: kinect openni sensor
Licenses: Apache
Conflicts: openni2
Provides: openni2
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 4
Popularity: 0.000027
First Submitted: 2017-03-01 00:08
Last Updated: 2018-12-31 21:39

Required by (9)

Sources (8)

Latest Comments

dbermond commented on 2017-03-15 04:57

@Teteros
It is fixed as of version 2.2.beta.r25.g1fce8ed-2.
Thanks for pointing this.

Teteros commented on 2017-03-12 17:14

Had to include "Driver" dir in includes to compile libfreenect2 with OpenNi2 support for the OniDriverAPI.h
May I suggest adding these lines in your PKGBUILD?

# directories creation
mkdir -p "${pkgdir}/usr/"{bin,include/openni2/{Driver,Linux-Arm,Linux-x86}}
# includes
install -D -m644 Driver/* "${pkgdir}/usr/include/openni2/Driver"