Package Details: openocd-git-libftdi r132.8fd59d7-1

Git Clone URL: https://aur.archlinux.org/openocd-git-libftdi.git (read-only)
Package Base: openocd-git-libftdi
Description: Debugging, in-system programming and boundary-scan testing for embedded target devices -using libftdi instead of ftd2xx
Upstream URL: http://openocd.org/
Licenses: GPL
Conflicts: openocd
Provides: openocd
Submitter: nickoe
Maintainer: nickoe
Last Packager: nickoe
Votes: 16
Popularity: 0.000000
First Submitted: 2009-10-23 18:59
Last Updated: 2015-06-22 22:26

Required by (4)

Sources (0)

Latest Comments

nickoe commented on 2015-05-16 16:28

I blindly updated with you suggested changes.

FreddieChopin commented on 2015-05-15 19:33

OK, while we're at it, a couple more things could be improved (;

1. "--enable-arm-jtag-ew" should be "--enable-armjtagew"

2. Some options worth adding:
--enable-aice
--enable-cmsis-dap
--enable-dummy
--enable-jtag_vpi
--enable-opendous
--enable-openjtag_ftdi
--enable-remote-bitbang
--enable-ti-icdi
--enable-ulink
--enable-usb-blaster-2

nickoe commented on 2015-05-15 15:40

Update with package function

FreddieChopin commented on 2015-05-15 15:09

When trying to install (with yaourt) I get this:

---

==> Building and installing package
==> ERROR: Missing package() function in /tmp/yaourt-tmp-freddie/aur-openocd-git-libftdi/./PKGBUILD
==> ERROR: Makepkg was unable to build openocd-git-libftdi.

---

It worked the last time I did the install, which was in November. Any help appreciated!

nickoe commented on 2014-06-04 13:28

I updated it to include both options.

nickoe commented on 2014-06-04 13:24

Could one safely use both options?

nickoe commented on 2014-06-04 13:20

Ok, I see that confiugure tells me, configure: error: The ft2232 driver is deprecated, use --enable-ftdi to build its replacement, or force the old driver with --enable-legacy-ft2232_libftdi

Is there any reason to use legacy and not just --enable-ftdi?

nickoe commented on 2014-06-04 13:16

@rami, what supercedes that driver since it is legacy now?

rami commented on 2014-06-04 12:29

In PKGBUILD:
--enable-ft2232_libftdi
has to be replaced by
--enable-legacy-ft2232_libftdi

nickoe commented on 2012-10-19 18:58

djvinz, thank you very much, I have now fixed it.

I like easy fixes :=)

All comments