Package Details: openoffice-uglyfix-freetype2 2.7-1

Git Clone URL: https://aur.archlinux.org/openoffice-uglyfix-freetype2.git (read-only, click to copy)
Package Base: openoffice-uglyfix-freetype2
Description: Compiles freetype2 .so files and puts them in the openoffice/libreoffice directory to fix font ugliness
Upstream URL: http://freetype.sourceforge.net
Licenses: GPL
Submitter: ilikenwf
Maintainer: TheGoliath
Last Packager: ilikenwf
Votes: 31
Popularity: 0.000000
First Submitted: 2008-12-11 03:59
Last Updated: 2016-12-02 02:11

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

fettouhi commented on 2010-12-10 18:06

Could this be updated to latest 2.4.4 of freetype2 and be compatible to klibreoffice insted of go-openoffice?

fettouhi commented on 2010-12-10 18:03

Could this be updated to latest 2.4.4 of freetype2 and be compatible to klibreoffice insted of go-openoffice?

fettouhi commented on 2010-12-10 18:03

Could this be updated to latest 2.4.4 of freetype2 and be compatible to klibreoffice insted of go-openoffice?

fettouhi commented on 2010-12-10 18:02

Could this be updated to latest 2.4.4 of freetype2 and be compatible to klibreoffice insted of go-openoffice?

Anonymous comment on 2010-09-10 16:03

This gives me the error:
error: failed to commit transaction (conflicting files)
openoffice-uglyfix-freetype2: /usr/lib/libfreetype.so.6.6.0 exists in filesystem

So I changed:
rm -rf ${pkgdir}/usr/lib/{pkgconfig,libfreetype.so,libfreetype.so.6,libfreetype.so.6.4.0}
To:
rm -rf ${pkgdir}/usr/lib/{pkgconfig,libfreetype.so,libfreetype.so.6,libfreetype.so.6.6.0}

fettouhi commented on 2010-09-04 20:39

Outstanding, many thanks!

ilikenwf commented on 2010-09-04 19:55

Done.

fettouhi commented on 2010-09-04 19:51

Can you update so that it uses freetype 2.4.2, since it is in [extra] now?

ilikenwf commented on 2010-09-04 19:37

Bump... I fixed that. Thanks for turning me onto go-openoffice, by the way...it's a lot faster...

Anyway, I added a little check to the build to put the file we compile in the proper directory, depending on which version is installed - openoffice-base or go-openoffice.

Rebuild and reinstall it, should work fine for you now.

Anonymous comment on 2010-09-04 17:38

I have installed it after go-openoffice and see absolutely no difference: the fonts are as useless as ever. What am I dong wrong? Also, how do I find out who made the package?