Package Details: openoffice 4.1.5-1

Git Clone URL: https://aur.archlinux.org/openoffice.git (read-only)
Package Base: openoffice
Description: Apache OpenOffice
Upstream URL: http://www.openoffice.org
Licenses: Apache
Conflicts: openoffice-base-bin-unstable
Replaces: openoffice-base-bin
Submitter: SibrenVasse
Maintainer: oberon2007
Last Packager: oberon2007
Votes: 31
Popularity: 0.008925
First Submitted: 2015-08-12 10:52
Last Updated: 2017-12-25 20:41

Dependencies (17)

Sources (2)

Latest Comments

1 2 3 Next › Last »

simona commented on 2018-08-11 09:35

Can I found openoffice-it-bin and manually install?

simona commented on 2018-08-11 09:15

Thanks :-) I like to have more choice.

oberon2007 commented on 2018-06-13 17:06

@ilkyest there is no newer version. Sources from Apache are still live and identical to the ones on SourceForge.

Cray2TheZ commented on 2018-01-07 20:30

My pleasure (first contribution to the Arch community! Woohoo :D)!

Thanks for the update!

oberon2007 commented on 2017-12-25 20:39

Thank you @Cray2TheZ. Updated.

Cray2TheZ commented on 2017-12-24 23:40

v4.1.4 does not install as its "durl" in PKGBUILD gives a 404 error.

durl needs to be set to point to the current version (4.1.5)

workaround was hard coding correct durl in PKGBUILD and passing the --skipchecksums option (along with -sri options) to the makepkg command.

I hope this helps!

sergey.orloff commented on 2016-12-10 13:27

Thanks, @oberon2007, the original version installed without a problem. I made corrections to installation of the Russian version slacking off on Your advice these lines in the file:

.SRCINFO
arch = x86_64
source_x86_64 = v4.1.3-x86_64::http://apache.org/dist/openoffice/4.1.3/binaries/ru/Apache_OpenOffice_4.1.3_Linux_x86-64_install-rpm_ru.tar.gz
md5sums_x86_64 = f6daf282fa92931ccfa9bce701b18295

PKGBUILD
_lang=ru
arch=('x86_64')
_durl="http://apache.org/dist/$pkgname/$pkgver/binaries/$_lang/Apache_OpenOffice_${pkgver}_Linux_x86"
source_x86_64=("v$pkgver-x86_64::${_durl}-64_install-rpm_ru.tar.gz")
md5sums_x86_64=('f6daf282fa92931ccfa9bce701b18295')

oberon2007 commented on 2016-12-10 10:32

Why? I don't think so! I've fixed the variable already a little earlier. In any case your version is not correct. Keep your $ outside the brackets! ;)

flapp commented on 2016-12-10 09:36

There is a very little mistake in the PKGBUILD.

_durl="http://apache.org/dist/$pkgname/$pkgver/binaries/$_lang/Apache_OpenOffice_${pkgver}_Linux_x86"

should be replaced by :

_durl="http://apache.org/dist/$pkgname/$pkgver/binaries/$_lang/Apache_OpenOffice_{$pkgver}_Linux_x86"

oberon2007 commented on 2016-12-10 09:14

Sorry, @sergey.orloff, there was a little typo. Fixed.