Package Details: opensees 2.5.0-2

Git Clone URL: (read-only)
Package Base: opensees
Description: OpenSees, a software framework for developing applications to simulate the performance of structural and geotechnical systems subjected to earthquakes
Upstream URL:
Licenses: custom
Submitter: mickele
Maintainer: mickele
Last Packager: mickele
Votes: 3
Popularity: 0.000000
First Submitted: 2009-09-27 14:15
Last Updated: 2016-10-01 15:39

Latest Comments

mickele commented on 2016-10-03 17:05

Thanks to nema.arpit now (2.5.0-2) package builds:
- OpenSees
- OpenSeesSP - parallel version
- OpenSeesMP - multithread version

nema.arpit commented on 2016-09-24 08:06

I have sent you an updated PKGBUILD for gcc6, and additions to compile OpenSeesMP and OpenSeesSP.
The md5um will need updating, or you'll need to use --skipinteg option for makepkg.
Apologies for misspelling your name in the mail.

bojurama commented on 2016-05-22 16:57

@nema.arpit: Thank you very much for your help. Compilation worked with gcc 5.3.

nema.arpit commented on 2016-05-21 02:49

@bojurama: That is an issue with gcc 6.1.1, I think. You can get past the error by adding the suggested flag, but then the compilation gets stuck in confinedConcrete01.cpp.
It compiles well with gcc 5.3.0, so you can try that out.

bojurama commented on 2016-05-20 23:50

OpenSees won't compile on my machine. The first error I get is the following one:

/usr/include/c++/6.1.1/type_traits:120:12: erreur fatale : template instantiation depth exceeds maximum of 30 (use -ftemplate-depth= to increase the maximum)
struct __or_<_B1, _B2>
compilation terminée.
../../../../Makefile.def:280 : la recette pour la cible « UmfpackGenLinSOE.o » a échouée
make[4]: *** [UmfpackGenLinSOE.o] Erreur 1
make[4] : on quitte le répertoire « /tmp/packerbuild-1000/opensees/opensees/src/OpenSees/SRC/system_of_eqn/linearSOE/umfGEN »
Makefile:7 : la recette pour la cible « all » a échouée

nema.arpit commented on 2016-01-31 09:22

Needs gcc-fortran as a dependency during make? Although, it is kinda expected to be installed if you are doing any serious scientific computations.

mickele commented on 2013-05-04 16:30

At last I updated the package!
I encountered some problems with the source.

mickele commented on 2011-12-26 12:29

Source of 2.3.2 isn't available as a tarball, so we have to donwload from SVN.

mickele commented on 2011-01-08 21:47

Updated to 2.2.2!

Anonymous comment on 2010-06-12 07:56

there is a new version!!!

All comments