Package Details: openssh-gssapi 8.2p1-1

Git Clone URL: https://aur.archlinux.org/openssh-gssapi.git (read-only, click to copy)
Package Base: openssh-gssapi
Description: Premier connectivity tool for remote login with the SSH protocol
Upstream URL: https://www.openssh.com/portable.html
Licenses: custom:BSD
Conflicts: openssh
Provides: openssh
Submitter: polslinux
Maintainer: christoph.gysin
Last Packager: christoph.gysin
Votes: 6
Popularity: 0.109446
First Submitted: 2015-10-26 09:37
Last Updated: 2020-03-10 21:26

Required by (213)

Sources (8)

Latest Comments

« First ‹ Previous 1 2

christoph.gysin commented on 2017-09-26 18:24

Thanks, I updated the package to my branch openssl-1.0-fix-keyexchange and cleaned up a bit. Will update to the later versions as soon as I get confirmation that they work as expected.

wallnuss commented on 2017-09-26 17:54

There is already a patchset against openssl-1.1... I was trying to take the entire patch list by Fedora and apply that here, but I was running into issues and out of time. @christoph.gysin if you want to take this PKGBUILD over please feel free to do so.

christoph.gysin commented on 2017-09-26 17:47

I have made some effort updating this package:
https://github.com/christophgysin/arch-openssh-gssapi/branches/yours

The different branches are different versions of the package:

- openssl-1.0: depend on and build against openssl-1.0
- openssl-1.0-fix-keyexchange: same as above, plus the fix mentioned by @mmrezaie
- openssh-7.5p1+openssl-1.0: updated to openssh-7.5p1
- openssh-7.5p1: ported to openssl-1.1

Feel free to test these and provide feedback using github issues or by email.

kaptoxic commented on 2017-07-10 15:20

Is this package still functional (mainly for SSH over Kerberos)? Can it still be updated?

mmrezaie commented on 2016-10-19 13:18

This package is not working at least with kerberos authentication. I shared the issue and there is a solution for it. You may check it out in here: http://unix.stackexchange.com/q/316930/106195. It works since I checked it myself.

polslinux commented on 2015-12-13 13:53

Done with rev 3.
Thanks jadelord :)

jadelord commented on 2015-12-13 10:38

Please change as follows:
Provides: openssh-7.1p1 -> openssh
i.e. in PKGBUILD provides=(${_pkgname})

If not openssh dependencies such as mpich, sshfs, package do not permit uninstallation of the original package.