Package Details: openvpn-update-resolv-conf r24.994574f-2

Git Clone URL: https://aur.archlinux.org/openvpn-update-resolv-conf.git (read-only)
Package Base: openvpn-update-resolv-conf
Description: OpenVPN Update resolvconf
Upstream URL: https://github.com/masterkorp/openvpn-update-resolv-conf
Licenses: GPL
Conflicts: openvpn-update-resolv-conf-git
Submitter: mtreinish
Maintainer: None
Last Packager: mtreinish
Votes: 26
Popularity: 1.400669
First Submitted: 2015-09-01 19:23
Last Updated: 2016-04-21 17:02

Latest Comments

archerie commented on 2017-09-16 16:09

Any activity on this?

noraj commented on 2017-06-20 20:24

hi mtreinish, can you name co-maintainer ?

sebstar commented on 2017-03-21 16:36

Please install script into /etc/openvpn/client/ and fix '-m755' to set the correct mode.

giovannicandido commented on 2017-03-19 22:22

solution for '-x command not found'

Edit /etc/openvpn/update-resolv-conf
change RESOLVCONF=$(which resolvconf)
to RESOLVCONF=/usr/bin/resolvconf

cb474 commented on 2017-03-06 02:30

/etc/openvpn/update-resolv-conf: line 56: -x: command not found
/etc/openvpn/update-resolv-conf: line 56: echo: write error: Broken pipe

lothar_m commented on 2017-01-08 15:51

I confirm archerie findings. As is, this PKGBUILD requires manual chmod.

archerie commented on 2016-09-17 19:48

This packages creates /etc/openvpn/update-resolv-conf but on my system that file has permissions created as 0655. It should be 0755 so that openvpn doesn't fail with this error:

Options error: --up script fails with '/etc/openvpn/update-resolv-conf': Permission denied

Skullcrasher commented on 2016-04-26 07:33

After updating the script did not update resolv.conf anymore. A possible fix is described here https://github.com/masterkorp/openvpn-update-resolv-conf/issues/15

mtreinish commented on 2016-04-21 17:04

@flamusdiu I've updated the PKGBUILD for both packages now to properly mark the conflict and the provides relationship between them.

flamusdiu commented on 2016-04-21 16:49

@mtereinish: You need to add 'provides' and 'conflicts' for both this and openvpn-update-resolv-conf-git packages. It would allow people to use either package to satisfy the requirement.

All comments