Package Details: openwmail 1.0.0-1

Git Clone URL: https://aur.archlinux.org/openwmail.git (read-only)
Package Base: openwmail
Description: The missing desktop client for Gmail & Google Inbox
Upstream URL: https://openwmail.github.io/
Licenses: MPL
Submitter: geekgonecrazy
Maintainer: geekgonecrazy
Last Packager: City-busz
Votes: 9
Popularity: 0.920208
First Submitted: 2017-05-05 17:24
Last Updated: 2018-07-26 19:19

Latest Comments

brenosilveira1 commented on 2018-10-24 04:20

The icon tray it is weird, just a yellow square with some transversal lines, it is right? https://imgur.com/a/mViFX1F

je-vv commented on 2018-10-08 00:41

I think the icon on "openwmail.desktop" should be "springmail", and not "openwmail", see:

% pacman -Ql openwmail | 'grep' 'icons.apps.[png|svg]'
openwmail /usr/share/icons/hicolor/128x128/apps/mailspring.png openwmail /usr/share/icons/hicolor/16x16/apps/mailspring.png openwmail /usr/share/icons/hicolor/24x24/apps/mailspring.png openwmail /usr/share/icons/hicolor/256x256/apps/mailspring.png openwmail /usr/share/icons/hicolor/32x32/apps/mailspring.png openwmail /usr/share/icons/hicolor/48x48/apps/mailspring.png openwmail /usr/share/icons/hicolor/512x512/apps/mailspring.png openwmail /usr/share/icons/hicolor/64x64/apps/mailspring.png openwmail /usr/share/icons/hicolor/96x96/apps/mailspring.png openwmail /usr/share/icons/hicolor/scalable/apps/mailspring.svg

Can it be fixed? Thx !

City-busz commented on 2018-07-26 19:21

Fixed.

@SMed79: Please close the upstream report, because it was a problem with an external module.

smed79 commented on 2018-07-26 14:55

It is impossible to build openwmail. see https://git.io/fNEMN

r0b0h0b0 commented on 2018-06-24 14:16

Getting an error while building. Anybody has any clues?

4927 error code ELIFECYCLE 4928 error errno 1 4929 error nodehun@2.0.11 install: `node-gyp rebuild` 4929 error Exit status 1 4930 error Failed at the nodehun@2.0.11 install script. 4930 error This is probably not a problem with npm. There is likely additional logging output above. 4931 verbose exit [ 1, true ]

Thank you!

City-busz commented on 2018-02-07 15:59

Now I replaced the previous PKGBUILD with a proper one, which uses system electron, and built from sources.

jesusrop commented on 2017-11-18 16:48

libxss shouls be added as dependence of this package. Otherwise openwmail refuses to run

btmcg commented on 2017-05-24 20:47

Here are the results of running namcap on the pkg.tar.xz file. Hope it's helpful:

$ namcap openwmail-1.0.0-4-x86_64.pkg.tar.xz
openwmail E: ELF file ('opt/openwmail/libffmpeg.so') outside of a valid path.
openwmail E: ELF file ('opt/openwmail/openWMail') outside of a valid path.
openwmail E: ELF file ('opt/openwmail/libnode.so') outside of a valid path.
openwmail W: ELF file ('opt/openwmail/openWMail') has executable stack.
openwmail E: MLP-2.0 is not a common license (it's not in /usr/share/licenses/common/)
openwmail W: Referenced library 'libffmpeg.so' is an uninstalled dependency
openwmail W: Referenced library 'libnode.so' is an uninstalled dependency
openwmail E: Symlink (usr/bin/openWMail) points to non-existing /home/btmcg/src/openwmail/pkg/openwmail/opt/openwmail/openWMail
openwmail W: Unused shared library '/usr/lib/libcups.so.2' by file ('opt/openwmail/openWMail')
openwmail W: Description should not contain the package name.
openwmail E: Dependency nss detected and not included (libraries ['usr/lib/libnss3.so', 'usr/lib/libsmime3.so', 'usr/lib/libnssutil3.so'] needed in files ['opt/openwmail/openWMail'])
openwmail E: Dependency alsa-lib detected and not included (libraries ['usr/lib/libasound.so.2'] needed in files ['opt/openwmail/openWMail'])
openwmail E: Dependency libxtst detected and not included (libraries ['usr/lib/libXtst.so.6'] needed in files ['opt/openwmail/openWMail'])
openwmail E: Dependency gtk2 detected and not included (libraries ['usr/lib/libgdk-x11-2.0.so.0', 'usr/lib/libgtk-x11-2.0.so.0'] needed in files ['opt/openwmail/openWMail'])
openwmail E: Dependency libxss detected and not included (libraries ['usr/lib/libXss.so.1'] needed in files ['opt/openwmail/openWMail'])
openwmail W: Dependency included and not needed ('libnotify')

btmcg commented on 2017-05-24 18:20

Thanks for supporting this.

After installing with pacaur:

$ pacaur -S openwmail

I was left with the following broken symlink:

$ ls -la /usr/bin/openWMail
lrwxrwxrwx 1 root root 73 2017-05-24 14:03 /usr/bin/openWMail -> /home/btmcg/.cache/pacaur/openwmail/pkg/openwmail/opt/openwmail/openWMail