Package Details: openwrt-devel 0.3-1

Git Clone URL: https://aur.archlinux.org/openwrt-devel.git (read-only, click to copy)
Package Base: openwrt-devel
Description: Metapackage to pull all dependencies required to build OpenWrt
Upstream URL: https://openwrt.org/docs/guide-developer/build-system/install-buildsystem
Licenses: GPL
Submitter: hsc
Maintainer: graysky
Last Packager: graysky
Votes: 4
Popularity: 0.24
First Submitted: 2019-01-06 18:37
Last Updated: 2021-02-07 11:24

Required by (0)

Sources (0)

Latest Comments

graysky commented on 2021-02-04 18:12

Hello.  I believe your metapackage is forcing more deps than are needed to compile openwrt.

  1. Any package in base-devel is an assumed dependency[1].
  2. A few others, although listed on the openwrt wiki are simply not needed.  You might move them to the optdepends.

Recommended changes:

depends=(
  bash bzip2 git libelf libxslt ncurses openssl python2 time unzip
  util-linux wget zlib
)

optdepends=(asciidoc help2man intltool perl-extutils-makemaker)
  1. https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

graysky commented on 2020-06-05 14:48

git needs to be a makedepends