Package Details: optimus-manager-qt-kde 1.6.9-1

Git Clone URL: https://aur.archlinux.org/optimus-manager-qt-kde.git (read-only, click to copy)
Package Base: optimus-manager-qt-kde
Description: A Qt interface for Optimus Manager that allows to configure and switch GPUs on Optimus laptops using the tray menu KDE
Upstream URL: https://github.com/Shatur/optimus-manager-qt
Keywords: intel kde nvidia optimus plasma qt
Licenses: GPL3
Conflicts: optimus-manager-qt
Submitter: lybin
Maintainer: Perfi
Last Packager: lybin
Votes: 2
Popularity: 0.073863
First Submitted: 2022-05-23 11:16 (UTC)
Last Updated: 2022-05-23 11:16 (UTC)

Latest Comments

hajakuu commented on 2023-12-17 10:41 (UTC)

Unfortunately because few Qt/kde packages has been renamed, there's no way to proceed with the updates for this package:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing knotifications5 (5.112.0-1) breaks dependency 'knotifications' required by optimus-manager-qt-kde
:: installing kiconthemes5 (5.112.0-1) breaks dependency 'kiconthemes' required by optimus-manager-qt-kde

Probably just replacing the dependencies in pckginfo:

knotifications kiconthemes

by

knotifications5 kiconthemes5

Should do the job here ;) But I have no idea if this will breaks other packages that depend on this one? Maybe the new package like optimus-manager-qt-kde5 should be created to follow changes in other Qt related packages? Sorry I couldn't help here, I have no idea if this really makes sense.

Workaround? ~Disable the updates

sudo vim /etc/pacman.conf   

add:

IgnorePkg   = knotifications5 kiconthemes5

badcast commented on 2023-10-20 13:58 (UTC)

fail install. Please fix it. required dependency

knotifications5 (5.111.0-1) breaks dependency 'knotifications' required by optimus-manager-qt-kde 
kiconthemes5 (5.111.0-1) breaks dependency 'kiconthemes' required by optimus-manager-qt-kde
kio5 (5.111.0-1) breaks dependency 'kio' required by systemd-kcm

archlegion commented on 2023-10-20 11:11 (UTC)

I get this, while updating with pacman. error: failed to prepare transaction (could not satisfy dependencies) :: installing knotifications5 (5.111.0-1) breaks dependency 'knotifications' required by optimus-manager-qt-kde :: installing kiconthemes5 (5.111.0-1) breaks dependency 'kiconthemes' required by optimus-manager-qt-kde

OS: Arch Linux x86_64 6.5.7-arch1-1
Desktop environment: KDE Plasma 5.27.8
Optimus Manager version: 1.5-4
Optimus Manager Qt version: 1.6.9-

lybin commented on 2022-06-02 16:24 (UTC)

https://aur.archlinux.org/packages/optimus-manager-qt#comment-866166