Package Details: origin-client-bin 4.1.0-1

Git Clone URL: https://aur.archlinux.org/origin-client-bin.git (read-only, click to copy)
Package Base: origin-client-bin
Description: The client tools for the Origin platform that powers OpenShift
Upstream URL: https://github.com/openshift/origin
Keywords: openshift
Licenses: Apache
Submitter: Changaco
Maintainer: thePanz
Last Packager: TheRepoClub
Votes: 16
Popularity: 0.34
First Submitted: 2016-01-22 19:19
Last Updated: 2020-12-30 23:27

Latest Comments

1 2 3 Next › Last »

thePanz commented on 2021-01-18 16:09

I agree @TiD91, the problem is that the source repository is not releasing the binary fine anymore :(

TiD91 commented on 2021-01-18 14:35

thePanz: Having the binary only is kinda useful since we can avoid downloading the Go dependency.

This package is ill packaged tho now!

thePanz commented on 2021-01-11 15:16

dmoebius: did you try using the https://aur.archlinux.org/packages/origin-client/ package? it is the OpenShift OC cli, build from sources (v4.6)

I would like to mark this package as abandoned, or merge it with origin-client. WDYT?

dmoebius commented on 2021-01-08 18:23

Btw. I don't know if oc client 4.1.0 is compatible with OKD server 3.11. Does anybody have a definite answer? Anyway, it might be a good idea to split this package into two packages "origin-client-bin" and "origin-client3-bin".

dmoebius commented on 2021-01-08 18:19

Thanks for updating the package to 4.1.0 @TheCynicalLiger, but it's packaged wrong: /usr/bin now longer contains the 'oc' binary, instead /usr/bin/oc/ is now a subdir containing the Go source code.

infabo commented on 2020-06-26 09:45

Sry for flagging this package again as out-of-date. There are sources that say, that 3.11 is the latest release. Apparently there is a 4.1.0 version. I don't know why they don't marked it as a release though.

madddi commented on 2019-11-09 12:57

Since this package got flagged out-of-date: This is the package for the OpenShift Origin (or OKD) client, which is the open source OpenShift version. The latest OKD release is still 3.11.

alwyn commented on 2018-08-13 08:25

Second time this package got updated and the checksums don't match :)

How do you update them? updpkgsums, manually or a different method?

==> Validating source files with sha256sums... bash-completions ... FAILED zsh-completions ... FAILED openshift-origin-client-tools-v3.10.0-dd10d17-linux-64bit.tar.gz ... Passed ==> ERROR: One or more files did not pass the validity check!

ILMostro7 commented on 2018-05-21 21:16

@madddi: thanks for the responses; your advice about the flags is duly noted.

madddi commented on 2018-05-16 11:10

@Cpt_Pi: the package was updated to v3.9 by me on 2018-04-24.

@ILMostro7: Please remove the completion files and download them again - the checksums are fine. Also, please don't flag the package out-of-date when you're having build problems. The package was updated to the latest version and v3.9 ist still the latest release.