Package Details: ormolu 0.5.0.0-2

Git Clone URL: https://aur.archlinux.org/ormolu.git (read-only, click to copy)
Package Base: ormolu
Description: A formatter for Haskell source code
Upstream URL: https://github.com/tweag/ormolu
Licenses: custom
Submitter: amesgen
Maintainer: geyaeb
Last Packager: geyaeb
Votes: 0
Popularity: 0.000000
First Submitted: 2020-01-13 04:34 (UTC)
Last Updated: 2022-05-13 10:46 (UTC)

Required by (0)

Sources (1)

Latest Comments

gesh commented on 2021-10-31 20:46 (UTC) (edited on 2021-11-01 16:16 (UTC) by gesh)

Please rename the source tarball to ${pkgname}-${pkgver}.tar.gz so that it's more distinct in a shared srcdir, eg as:

commit 4283fb646d2a66f0e91617dc326ac910d08aa130 (HEAD -> local)
Author: gesh <gesh@gesh.uni.cx>
Date:   Sun Oct 31 22:45:34 2021 +0200

    Rename source tarball for uniqueness

diff --git a/PKGBUILD b/PKGBUILD
index f5502f6..7af5292 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@

 pkgname=ormolu
 pkgver=0.3.1.0
-pkgrel=1
+pkgrel=2
 pkgdesc="A formatter for Haskell source code"
 arch=('i686' 'x86_64')
 url="https://github.com/tweag/${pkgname}"
 license=('custom')
 depends=('gmp')
 makedepends=('stack')
-source=("${url}/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
 sha256sums=('b0bbf229f1878c39aa58dbb71d8cc4fbc4713252c7acbc0fd9921804fecbd273')

 build() {

gesh commented on 2021-10-17 15:22 (UTC)

Note https://github.com/tweag/ormolu/issues/776 was closed, no need to ship stack.yaml anymore.

gesh commented on 2021-09-14 22:40 (UTC)

Please keep an eye on the suggested stack.yaml, package currently doesn't build since it is out of date. It is unclear where you picked lts-15.11 from -- c261356 has the recommendation jump from lts-14.3 to lts-16.0. Have opened https://github.com/tweag/ormolu/issues/776 upstream to hopefully ease this. Current rec:

resolver: lts-18.6
packages:
- '.'
extra-deps:
- Cabal-3.4.0.0
- ghc-lib-parser-9.0.1.20210324

Checked, and it builds

emilime commented on 2021-02-14 13:42 (UTC)

Hello, I got this error while trying to build:

==> Starting package()...
You are not the owner of '/home/user/.stack/'. Aborting to protect file permissions.
Retry with '--allow-different-user' to disable this precaution.
==> ERROR: A failure occurred in package().

Apparently, it is stack which complains. A workaround is to add

allow-different-user:true

To the global stack config at ~/.stack/config.yaml, or perhaps the flag can be added to the package() function.